summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pytest-mock
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest4
-rw-r--r--dev-python/pytest-mock/metadata.xml3
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.7.0.ebuild39
3 files changed, 42 insertions, 4 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 8f697c3e899b..101c59aa8d6d 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,3 +1,5 @@
DIST pytest-mock-3.6.1.tar.gz 29933 BLAKE2B 6c22d23f3a8e9b5ef26f990325f5a2c2897b60f61f84472716a1f984e72a8c38f6992e439ef581d7772e25a5fe9e76d190697d9c7bc8b5dcbf6375bead4b3dc3 SHA512 50a8ffbac1b20b1962558789b24d50c1e7d8d2e2706ee15a576eb5fd1b40d4523482dce7a1078d532b686ff8d38b6d769d356b04241528a0196e14acae0b6199
+DIST pytest-mock-3.7.0.tar.gz 29311 BLAKE2B 27227b66008c70c4016c8e15d0021a67e84730a8b49c5664dc4f29e16d5f163df293269ab332707e44b7a0b182e15e20ab0ebaf4b9d923eb911083377972dad1 SHA512 6ba69e86bac8a430a9f1f1c615ad21f505b87848ac50fc551bc02f81306bf8769fd015615d96085d87d4c695c24b0686a95116721358687b48b64de5d0ae6901
EBUILD pytest-mock-3.6.1.ebuild 950 BLAKE2B 7346bbf6bee0fafd0f90cf1d2139343597095bd9807cf8a616833598ffc6b2af014aa6034deb8ecca9f0ce397924e22e3f440a67f070ac6504a76ca563d90913 SHA512 1a0645374bb334ec8e212e3efab72dac4dc6b9fe50ecb3f0fe7454752ec507cccadccf57e46cfd30986b779df92c590ff85c7a77c30c3185a72b0abebeb4b10b
-MISC metadata.xml 458 BLAKE2B 1f30330ee4d263236a048cfd114c4129df9b5a7a78a35af366903ecd273ff34b353516f56874870b06b4d39e3c5a0c5300d3455b784193b168dd13b8c9aabba0 SHA512 87a4daaaa39a6d551ab677370c815dccd377a0e6d30cb56e346dd0343d3f099557a1f95156983fb9e2eaedfc4e142dd1faac7a9cb01e72442644b0f4c7a91093
+EBUILD pytest-mock-3.7.0.ebuild 987 BLAKE2B 3d2f93a8a80bfe29c9e67a7b6ae68be6fcf671da01692b6a075eb41088549500631bb9dd6e6548891e002df8a9fdd212b36a0c9327a385ef5d4a2716a0dd74a6 SHA512 cf5c3251f000143c404479857a6cbbcea098c3f063f55f920d16b22ed19cf819a12ad5f595ac182d99cf4a8f25601ed821626c7abf669586ce3265c80932f615
+MISC metadata.xml 379 BLAKE2B 47a45606cecad3ecc9b902d9ec690c33a89728ce93038433f11ab8c3369089ef12e86c793ab06dedeef7a816dc973ae8ea2a6b717b13085c7912d69bcd68db65 SHA512 b5e43e5e0a1cfba50868ca542b00d40084aeb38f764f203ed112a9359e966e94d34a99bbb072b98f9401a0383d3fbf834b8b87572e073592263f18d73f09db2e
diff --git a/dev-python/pytest-mock/metadata.xml b/dev-python/pytest-mock/metadata.xml
index f1dff6d6b29e..ce2ad5348355 100644
--- a/dev-python/pytest-mock/metadata.xml
+++ b/dev-python/pytest-mock/metadata.xml
@@ -6,9 +6,6 @@
<remote-id type="github">pytest-dev/pytest-mock</remote-id>
</upstream>
<stabilize-allarches/>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- </maintainer>
<maintainer type="project">
<email>python@gentoo.org</email>
</maintainer>
diff --git a/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
new file mode 100644
index 000000000000..3e6c060c2c67
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
+
+ if has_version dev-python/mock; then
+ local EPYTEST_DESELECT=(
+ tests/test_pytest_mock.py::test_standalone_mock
+ )
+ fi
+
+ epytest --assert=plain
+}