summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-mock
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest5
-rw-r--r--dev-python/pytest-mock/metadata.xml11
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.6.0.ebuild40
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.6.3.ebuild40
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
new file mode 100644
index 000000000000..ea404980750f
--- /dev/null
+++ b/dev-python/pytest-mock/Manifest
@@ -0,0 +1,5 @@
+DIST pytest-mock-1.6.0.tar.gz 17780 BLAKE2B 4fbc0cbd951668eb2ce427496c54e958591fe368bd42544eb1d0379adcb3d0e10b223ab044956e4003aac88665b3132dcb9d167442d6d85a5be79edea36881ca SHA512 c3b897be9156d57d7012e95b620c543500b849d7076224e3328d3783311210c57141dfb82c01bb98e5e419125dce0f68f6631bd610f4909f5ac1798458a7949f
+DIST pytest-mock-1.6.3.tar.gz 18482 BLAKE2B 1c0d366e5afd1b247ff454716b6d96d9d68846adfff81adc0ea079a72d3e7710fd9385122723cfee69965588235ec2deb1e0b52328ace5c967652c93b404cea3 SHA512 6857f373728d3f2c6b152d4f89da3590e2e74795695dc9f4f3704a4e0250e49d705ce0de4121a801ac35c83217678a95a5023338124293ca74db406941f5072a
+EBUILD pytest-mock-1.6.0.ebuild 1068 BLAKE2B 001bdcb3d8aa15ae46ccae85fabebdae90cbdc7e9f3a804f05c4984daa0532b39b2d738a36c8b154ff03469b673a3c6d424775de4c277aaac59857671bb831b8 SHA512 712dd100338130ab0306632b7832dee14fffee2de39d3b785b6cf0b4ca2b447fd09fc75fb7c4f714702aa6b8094168178b3a7b71ee7b3e7a42921fe459f4eec4
+EBUILD pytest-mock-1.6.3.ebuild 1070 BLAKE2B 950a7986e97c5e2444b67503a86d268bcba7550bd3f73a488137d16ba5760d1b561053e9a7074217d8c32c8f8aa6fc20b5f0cea1bec684551eac84b0a0625222 SHA512 1b21e9b8689b143c966b9feb4fcb1ca3d086709c13c3bfa374ba859f1fdaf33046abfd630dfc39e5f9b6b6fcb12c434b45e79d61d5fcb29f5a1350fc3cb980d5
+MISC metadata.xml 354 BLAKE2B eeb8bdbdcc7cebcb451e7c40a2ed5d0136d35e6b6a63e79e1df73762b40302e16abb4263e8c4cae8f1cf5849377cf6ea12c7ccb042737d63ec75252ca99f511e SHA512 83a168d22f4d604827aa42966ccd1b99d53f069cdfffe69b29fad8f13c4959ff287915c0fdc29e53ce2c3d5625b4f4620861b927571dc91c93ac199a5985a3da
diff --git a/dev-python/pytest-mock/metadata.xml b/dev-python/pytest-mock/metadata.xml
new file mode 100644
index 000000000000..6c61486a96fd
--- /dev/null
+++ b/dev-python/pytest-mock/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-mock</remote-id>
+ <remote-id type="github">pytest-dev/pytest-mock</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-mock/pytest-mock-1.6.0.ebuild b/dev-python/pytest-mock/pytest-mock-1.6.0.ebuild
new file mode 100644
index 000000000000..80f4d4912349
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ >=dev-python/mock-2[python_targets_python2_7]
+ )
+ python_targets_pypy? (
+ >=dev-python/mock-2[python_targets_pypy]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test test_pytest_mock.py || die
+}
diff --git a/dev-python/pytest-mock/pytest-mock-1.6.3.ebuild b/dev-python/pytest-mock/pytest-mock-1.6.3.ebuild
new file mode 100644
index 000000000000..4d4ced48dfbc
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-1.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ >=dev-python/mock-2[python_targets_python2_7]
+ )
+ python_targets_pypy? (
+ >=dev-python/mock-2[python_targets_pypy]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
+ py.test test_pytest_mock.py || die
+}