summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-python/pytest-mock
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest4
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.10.0.ebuild35
-rw-r--r--dev-python/pytest-mock/pytest-mock-1.6.3.ebuild15
3 files changed, 43 insertions, 11 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index ea404980750f..4e807224393b 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,5 +1,7 @@
+DIST pytest-mock-1.10.0.tar.gz 20754 BLAKE2B db60bfe6ee9d6d0a6ee4f0df7f5efa6ef05f5e2360945aa86ff6de02fc6a01f1e6715cbb61ced0c1e737c300965835fb08727b926852c5b71c0cc3d56c1171f1 SHA512 b8afba13da3e598b6493459298e395c0ecc06538733916659191bd5c5c22f40b0e296853ad940c16a6d492fcf46b2daf490ee589661d391e2c7cd1deb84da756
DIST pytest-mock-1.6.0.tar.gz 17780 BLAKE2B 4fbc0cbd951668eb2ce427496c54e958591fe368bd42544eb1d0379adcb3d0e10b223ab044956e4003aac88665b3132dcb9d167442d6d85a5be79edea36881ca SHA512 c3b897be9156d57d7012e95b620c543500b849d7076224e3328d3783311210c57141dfb82c01bb98e5e419125dce0f68f6631bd610f4909f5ac1798458a7949f
DIST pytest-mock-1.6.3.tar.gz 18482 BLAKE2B 1c0d366e5afd1b247ff454716b6d96d9d68846adfff81adc0ea079a72d3e7710fd9385122723cfee69965588235ec2deb1e0b52328ace5c967652c93b404cea3 SHA512 6857f373728d3f2c6b152d4f89da3590e2e74795695dc9f4f3704a4e0250e49d705ce0de4121a801ac35c83217678a95a5023338124293ca74db406941f5072a
+EBUILD pytest-mock-1.10.0.ebuild 1028 BLAKE2B cbd60a3bcee5a94bd6d665b10e6652dec896ee8b678f07d0e8dcc2629447646a3f2c5ab3607b0b00c023b5f49eebb1825f7e49455280e84921f98400558260ac SHA512 cbbc0dd41de2e126585dec4d5033192e42ea151906dfb05043eb0af54e663134e4b1d62ac455119eb802b7361bb8b7c8c975da028a7e1ea9765971d195c7d8ac
EBUILD pytest-mock-1.6.0.ebuild 1068 BLAKE2B 001bdcb3d8aa15ae46ccae85fabebdae90cbdc7e9f3a804f05c4984daa0532b39b2d738a36c8b154ff03469b673a3c6d424775de4c277aaac59857671bb831b8 SHA512 712dd100338130ab0306632b7832dee14fffee2de39d3b785b6cf0b4ca2b447fd09fc75fb7c4f714702aa6b8094168178b3a7b71ee7b3e7a42921fe459f4eec4
-EBUILD pytest-mock-1.6.3.ebuild 1070 BLAKE2B 950a7986e97c5e2444b67503a86d268bcba7550bd3f73a488137d16ba5760d1b561053e9a7074217d8c32c8f8aa6fc20b5f0cea1bec684551eac84b0a0625222 SHA512 1b21e9b8689b143c966b9feb4fcb1ca3d086709c13c3bfa374ba859f1fdaf33046abfd630dfc39e5f9b6b6fcb12c434b45e79d61d5fcb29f5a1350fc3cb980d5
+EBUILD pytest-mock-1.6.3.ebuild 1028 BLAKE2B cbd60a3bcee5a94bd6d665b10e6652dec896ee8b678f07d0e8dcc2629447646a3f2c5ab3607b0b00c023b5f49eebb1825f7e49455280e84921f98400558260ac SHA512 cbbc0dd41de2e126585dec4d5033192e42ea151906dfb05043eb0af54e663134e4b1d62ac455119eb802b7361bb8b7c8c975da028a7e1ea9765971d195c7d8ac
MISC metadata.xml 354 BLAKE2B eeb8bdbdcc7cebcb451e7c40a2ed5d0136d35e6b6a63e79e1df73762b40302e16abb4263e8c4cae8f1cf5849377cf6ea12c7ccb042737d63ec75252ca99f511e SHA512 83a168d22f4d604827aa42966ccd1b99d53f069cdfffe69b29fad8f13c4959ff287915c0fdc29e53ce2c3d5625b4f4620861b927571dc91c93ac199a5985a3da
diff --git a/dev-python/pytest-mock/pytest-mock-1.10.0.ebuild b/dev-python/pytest-mock/pytest-mock-1.10.0.ebuild
new file mode 100644
index 000000000000..ca329f1b7442
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-1.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with py.test"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-2[${PYTHON_USEDEP}]' -2)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH}
+ py.test -vv test_pytest_mock.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/pytest-mock/pytest-mock-1.6.3.ebuild b/dev-python/pytest-mock/pytest-mock-1.6.3.ebuild
index 4d4ced48dfbc..ca329f1b7442 100644
--- a/dev-python/pytest-mock/pytest-mock-1.6.3.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-1.6.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
inherit distutils-r1
@@ -16,12 +16,7 @@ KEYWORDS="~amd64 ~arm64 ~x86"
IUSE=""
RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
- python_targets_python2_7? (
- >=dev-python/mock-2[python_targets_python2_7]
- )
- python_targets_pypy? (
- >=dev-python/mock-2[python_targets_pypy]
- )"
+ $(python_gen_cond_dep '>=dev-python/mock-2[${PYTHON_USEDEP}]' -2)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]"
@@ -35,6 +30,6 @@ src_prepare() {
}
python_test() {
- PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH} \
- py.test test_pytest_mock.py || die
+ local -x PYTHONPATH=${PWD}${PYTHONPATH:+:}${PYTHONPATH}
+ py.test -vv test_pytest_mock.py || die "Tests fail with ${EPYTHON}"
}