summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock/pytest-mock-3.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-python/pytest-mock/pytest-mock-3.3.1.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-python/pytest-mock/pytest-mock-3.3.1.ebuild')
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.3.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/pytest-mock-3.3.1.ebuild b/dev-python/pytest-mock/pytest-mock-3.3.1.ebuild
new file mode 100644
index 000000000000..a646df8a08aa
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-3.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pytest-5[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ if has_version dev-python/mock; then
+ # test fails when standalone mock is installed
+ sed -e 's|^\(def \)\(test_standalone_mock(\)|\1_\2|' -i tests/test_pytest_mock.py || die
+ fi
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest --assert=plain -vv || die "Tests fail with ${EPYTHON}"
+}