summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localserver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-03 19:35:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-03 19:35:31 +0000
commited43421253416ff58a637be8932ac1d7b7b232de (patch)
tree3cf7b0046bd17c3d59b7621101a7fd606fc2662b /dev-python/pytest-localserver
parent2d644a12e4e4d5061eeff8d068db29d562eba35b (diff)
gentoo auto-resync : 03:03:2023 - 19:35:31
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest4
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.7.0.ebuild41
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.7.1.ebuild6
3 files changed, 4 insertions, 47 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index 4c502f57e09a..5cf8f6550440 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-localserver-0.7.0.tar.gz 184154 BLAKE2B 31f05dd4f156c8a547dacaf39c1aa1a576f2f84e625d64b96409212768a7d9967944931f85ab293d26f348e3a65eba1c5e341c6c08992271c10e65b2fa453cc4 SHA512 1fb1acaeb190d35ebd05cdd63ce15e4a9138802901cef8c25c1fa6dd177d8af2b6b2749f5a052942bf655ffd2ff6105de8a652d73faab369ce6dcf3219bb2394
DIST pytest-localserver-0.7.1.tar.gz 185617 BLAKE2B 2ef2bb38c03c3ad05f9ef038f03e071e4d18bf256d76357c1a980f917228392a863bef088f46bd43acae23457a5141048f93d607d1b3e6757f238ce27b9e9584 SHA512 fd32ea020152a17fb1dcfe3f5cccd5c2a26eed18b711f51c5c7cb8534862706e6738651c275e88f3cbad54ecdb59e4b5588e67eed0ff3bbf20c3636e97990ed6
-EBUILD pytest-localserver-0.7.0.ebuild 933 BLAKE2B d600e6936a4951456285cbebb2436954f65e21a8018d253d8fc79228bd8ff0f4d7a5acfa57b43b46bad21af71e054e09a239d986676388b47727801731500602 SHA512 b9bb6c1b4432002f9add0e0ce7c42cea0a1d5f53aa63d80bba133bbab77ad8539d40c36c288163a4b5c1377da7f01f524abf519abf61d4056fe7349b1fe47f85
-EBUILD pytest-localserver-0.7.1.ebuild 941 BLAKE2B 4c83b83f889d63ec36bbd099d09bcba44212e7d46e7ce96ff6692992118c273fa6a122ee7baa6e1b1f3103f643e851d93871b6ab63b79955be7cd89ef905ab73 SHA512 b9346f4cbf11d724ed2e2d86c845d8b4903398a6040becd540511894caa5990f26e41cc1261f415c8c680d499db73dfab1c8796c9cd5d1bd846d8522640f0d40
+EBUILD pytest-localserver-0.7.1.ebuild 906 BLAKE2B 73df7e4b9f894ed79fac044b4dfdb5efd29c0ab482750e2858bf763c7fe3e42b3ac5b7ca44ff1161aa9e42e80ef82449a5cd9440b33b078c68cc60f77b713ca9 SHA512 ab74d4120d49d187bab3579a54387226e2d7468c22ece4558060a03d32d529faaf14ea0356e037570dd787f161e766d2c8803b8a8e9980ce7c636648268a66c2
MISC metadata.xml 415 BLAKE2B e9793de9ce60bde1549abb0983ca145f55261653324785d735c91785a20b61d949c228528faa742d669d52c1f456a36c65a93c1e9a692ec9297d4ffcfc0123fe SHA512 e0e7819a4b1bd41301824727b2204092986ba4d0c56fe1530b40543fcf7b90541933a7b8094f24a0573854b76b9ce11b7b42d2e38d135f61fed9b498f05f98e1
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.7.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.7.0.ebuild
deleted file mode 100644
index 6f9b022963d2..000000000000
--- a/dev-python/pytest-localserver/pytest-localserver-0.7.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pytest plugin to test server connections locally"
-HOMEPAGE="https://pypi.org/project/pytest-localserver/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # requires aiosmtpd that is dead and broken beyond repair
- tests/test_smtp.py
-)
-
-src_prepare() {
- # remove aiosmtpd dep
- sed -e '/aiosmtpd/d' -i setup.py || die
- distutils-r1_src_prepare
-}
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.7.1.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.7.1.ebuild
index 66639fc7e118..87bbb4b4d110 100644
--- a/dev-python/pytest-localserver/pytest-localserver-0.7.1.ebuild
+++ b/dev-python/pytest-localserver/pytest-localserver-0.7.1.ebuild
@@ -4,17 +4,17 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{9..11} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Pytest plugin to test server connections locally"
HOMEPAGE="https://pypi.org/project/pytest-localserver/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
RDEPEND="
>=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]