summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localserver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/pytest-localserver
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest4
-rw-r--r--dev-python/pytest-localserver/files/pytest-localserver-0.5.0-py310-tests.patch39
-rw-r--r--dev-python/pytest-localserver/files/pytest-localserver-0.5.0-setup.patch5
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild9
4 files changed, 54 insertions, 3 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index 970fbad8a371..1beaff66cabc 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1,3 +1,5 @@
+AUX pytest-localserver-0.5.0-py310-tests.patch 1608 BLAKE2B d11471960e35b43150f2783b728e2f763e8b3b54a4a8a3fcc56fd12b6c230d03ffaa9826ee20c83865754c95b75c35343e3038d32b2e792fbf9975bbb936c961 SHA512 149526734f33dbb7903cf8381f6eca7cea7a0a3c452759a16d7a0ee8d415bd767722acde88189865eab769ff4506d209155df1e02e130effc724c4306f8cf99f
+AUX pytest-localserver-0.5.0-setup.patch 170 BLAKE2B a82759d54b0ff9f7f457ca9e3665d68b05c92063ea4dd47bb4e5932999cb600aac9bda9367d33dc7911d0294932a30f52c618cd7f2f9b9db24b279efe64e79ab SHA512 75df9fe8dbcb38151478bb7039bb56a4fc00fea5f7867044ebab90260f7289930090f84727b1e449c95baa4fd275cd277fae5fcbad283e1f84ab72f6277d0926
DIST pytest-localserver-0.5.0.tar.gz 20409 BLAKE2B 62376065ee1aeb698ea5e3bd2d5ea3d6b511cc6793142aad458423513b0e3b358a0d0269a78a0f5aeda44fc53757ff85da786627840ee48cbed8b78ee34c2227 SHA512 aedf1e1c9563396457070df13df228ad0ebdd19173fa2ac5a598288d3e1a1ac8b8a0c0288cba0d8478e43d2e1de4848f2393bf640705916957f12ab31171c6cc
-EBUILD pytest-localserver-0.5.0.ebuild 691 BLAKE2B 36f50956f4a53638b821b6690cab5e8fcb3a6d7e7c2e45ff5c8eabf8b57a2177ccd16d683439d9a2feb6ffa1cbc9aef2b74eb220a69817b43759889782b931ae SHA512 66ae0c1801a772f0e3d481b35cbab202cf55e5dfdef58dfa1fb0698e2ad098d4ad49c90600ce2fb3db725b408d4320590141c42012e4aaf89a4a839d3af6cdd9
+EBUILD pytest-localserver-0.5.0.ebuild 814 BLAKE2B 4443f00387096757315f3c7d50698772c7b102d334339a63c123d59ea996c990282029734a152e9233dd4c4cfccc364577c3497da67ab321e53c5caddc8fe5b4 SHA512 6d63c912da6eda8f6c9adc4452670323dc9e99ae7a0239dad11f354c72ecfbfb7ceac7552132bc6f73c91212fde6fa58386e8b1bd92e5b082513f2a2ca9b20b7
MISC metadata.xml 345 BLAKE2B 79e94a8ee25d0f7284462fc21638c20778f60d0f8cf2e84f6904bedc165293c5f13335b3bc2976cf6bd0170fdb0be80b52b256a3abfdb9eacbaa98661a9466b8 SHA512 5a2e28bdb0a20b1a04e1f549130a7f1bf3b33fdd176baa50db33e999540474abe091bcf8ad76c4554a0e046dec7466c72f0786acaa87c88e72f6164891c3decd
diff --git a/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-py310-tests.patch b/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-py310-tests.patch
new file mode 100644
index 000000000000..c9a8fbf0f870
--- /dev/null
+++ b/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-py310-tests.patch
@@ -0,0 +1,39 @@
+--- a/tests/test_https.py 2021-05-24 12:10:07.335676451 -0700
++++ b/tests/test_https.py 2021-05-24 12:10:23.966572498 -0700
+@@ -11,17 +11,20 @@
+ httpsserver = plugin.httpsserver
+
+
++@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
+ def test_httpsserver_funcarg(httpsserver):
+ assert isinstance(httpsserver, https.SecureContentServer)
+ assert httpsserver.is_alive()
+ assert httpsserver.server_address
+
+
++@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
+ def test_server_does_not_serve_file_at_startup(httpsserver):
+ assert httpsserver.code == 204
+ assert httpsserver.content == ''
+
+
++@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
+ def test_some_content_retrieval(httpsserver):
+ httpsserver.serve_content('TEST!')
+ resp = requests.get(httpsserver.url, verify=False)
+@@ -29,6 +32,7 @@
+ assert resp.status_code == 200
+
+
++@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
+ def test_GET_request(httpsserver):
+ httpsserver.serve_content('TEST!', headers={'Content-type': 'text/plain'})
+ resp = requests.get(httpsserver.url, headers={'User-Agent': 'Test method'}, verify=False)
+@@ -37,6 +41,7 @@
+ assert 'text/plain' in resp.headers['Content-type']
+
+
++@pytest.mark.skipif(sys.hexversion >= 0x30a0000, reason="Example certs too weak for py310")
+ def test_HEAD_request(httpsserver):
+ httpsserver.serve_content('TEST!', headers={'Content-type': 'text/plain'})
+ print(httpsserver.url)
diff --git a/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-setup.patch b/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-setup.patch
new file mode 100644
index 000000000000..1cad7643973a
--- /dev/null
+++ b/dev-python/pytest-localserver/files/pytest-localserver-0.5.0-setup.patch
@@ -0,0 +1,5 @@
+--- a/setup.cfg 2021-05-24 12:19:38.163108453 -0700
++++ b/setup.cfg 2021-05-24 12:19:58.714979990 -0700
+@@ -2 +2 @@
+-description-file = README
++description_file = README
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
index 21a6b9cdda9f..b995790ef5d4 100644
--- a/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
+++ b/dev-python/pytest-localserver/pytest-localserver-0.5.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -24,4 +24,9 @@ BDEPEND="
dev-python/six[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}/pytest-localserver-0.5.0-setup.patch"
+ "${FILESDIR}/pytest-localserver-0.5.0-py310-tests.patch"
+)
+
distutils_enable_tests pytest