summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-12 12:14:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-12 12:14:42 +0100
commit3a0e100e02e1c6c2818268f57eae51095cee35af (patch)
treefdc72a395f9087c6e6dfa08b8a1791f65c5af170 /dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild
parentb71bf04bdb3f690dbd36fcda860a5a68c1988f6e (diff)
gentoo auto-resync : 12:10:2023 - 12:14:42
Diffstat (limited to 'dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild')
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild
new file mode 100644
index 000000000000..f7374f4e1937
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin to test server connections locally"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-localserver/
+ https://pypi.org/project/pytest-localserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires aiosmtpd that is dead and broken beyond repair
+ tests/test_smtp.py
+)
+
+src_prepare() {
+ # remove aiosmtpd dep
+ sed -e '/aiosmtpd/d' -i setup.py || die
+ distutils-r1_src_prepare
+}