summaryrefslogtreecommitdiff
path: root/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-29 18:57:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-29 18:57:21 +0000
commit8455eae17683fbd2c785ca4b8443581622f388c7 (patch)
tree51bb7aac8b41b8f6e692f9e5b4e65001315b43fd /dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild
parentb2f1788f6f0365b76f55f257b2d170c1e68a8640 (diff)
gentoo auto-resync : 29:01:2024 - 18:57:21
Diffstat (limited to 'dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild')
-rw-r--r--dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..500904a50a46
--- /dev/null
+++ b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="It helps to use fixtures in pytest.mark.parametrize"
+HOMEPAGE="
+ https://github.com/tvorog/pytest-lazy-fixture/
+ https://pypi.org/project/pytest-lazy-fixture/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest