summaryrefslogtreecommitdiff
path: root/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-04 08:14:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-04 08:14:38 +0100
commitf4e04dc11a0252f8c6c535b7538703974cd06ea0 (patch)
tree6ba3be4a2ac2e0f44768521ed50444220fcfec85 /dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
parentba32ac7204934e0c69e1cc7529edce6efdbeb265 (diff)
gentoo auto-resync : 04:04:2024 - 08:14:38
Diffstat (limited to 'dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild')
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
new file mode 100644
index 000000000000..ac7134dabd4e
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/pytest-jupyter/
+ https://pypi.org/project/pytest-jupyter/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.7[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest