summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/pytest-httpx
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest5
-rw-r--r--dev-python/pytest-httpx/metadata.xml14
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.10.1.ebuild30
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.11.0.ebuild30
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
new file mode 100644
index 000000000000..87cc3d38ada2
--- /dev/null
+++ b/dev-python/pytest-httpx/Manifest
@@ -0,0 +1,5 @@
+DIST pytest-httpx-0.10.1.tar.gz 21117 BLAKE2B 372ecc8a132f28bf7016ed466c4f6974f51c3c2ab9decd68fd8e3c7a810030db9f169f5ab28662cfed006297ea200d3a157ba220f2156b44be03fbf49edc5415 SHA512 f306e57408924b653d3ab4dd28f266b066f202b98440b31769940bdab0be98d5c48817e22d68e2dcdf82426e26334242591d0ae630aa71812f81dd7866b81e0f
+DIST pytest-httpx-0.11.0.tar.gz 21178 BLAKE2B c58c303868fd1b1926a58db28eeda3c5d74cd38f68aad3543cb0296f4dcac59d9fb983287b432219f70bd2003c2a0e32d85ed343b1c279d576ef100b129c7f25 SHA512 eb798d31c710ab50d3176c569aba8ae2131a17f415fe87830fc71aa941d638bdbda4296032a07fce98d9a43a57f250cea380f8c409660eb1f13862094b6fcbb6
+EBUILD pytest-httpx-0.10.1.ebuild 652 BLAKE2B 46e3a52a92fa0a41113b83ab484f788ffefab9b78b1131d4ac93a10cf66a434353a18f2190f654232c6dac93448c56fdb94497f61b45f06f0e1ff6fccf06ed9d SHA512 deb414435242646088536df2966488bc188596d953d8c53c6957cd92b2ac2250b7840747c6198fa1068ae05821a1495aa966ed1e564247d0a1a1530ff5c53fc9
+EBUILD pytest-httpx-0.11.0.ebuild 652 BLAKE2B 874b81051af4bbb2aaae6f0b45db7b5ea0deca1c63b32eb903591598268ae3776fce86a0211bbb5307d5f904741c240d0c23ddfa9ebdad0427693b007d34fa28 SHA512 eb0530d3b446928dd6e6bde6a9a79c49307184f4bf3ca5b033db2f5bb37862867a72d48f16d33a2204fdcafb84ef9ff334739c7002d3c5497688eaf63b991360
+MISC metadata.xml 467 BLAKE2B d13bfcccc41321e84d9e912be5e6106c376d7dd5a8bc596e69e570713fb2d0dee3627e29dc9c35c6638322c7edd328a6f60e6af8dc967fad302508dcfded32be SHA512 a6b6cc298ccbbc4b11c0e91a4402f634ee0f69e5ee53e09648f842771b8d6f3fdebe5114b3f55623b75e6539a794b6b94956a6eaf4e7f91e28eb6d4bcbb5f770
diff --git a/dev-python/pytest-httpx/metadata.xml b/dev-python/pytest-httpx/metadata.xml
new file mode 100644
index 000000000000..fd29bd901502
--- /dev/null
+++ b/dev-python/pytest-httpx/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-httpx</remote-id>
+ <remote-id type="github">Colin-b/pytest_httpx</remote-id>
+ <bugs-to>https://github.com/Colin-b/pytest_httpx/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.10.1.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.10.1.ebuild
new file mode 100644
index 000000000000..b2f04c25ff37
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.10.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.16*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.11.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.11.0.ebuild
new file mode 100644
index 000000000000..6b38ce967264
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.11.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="https://colin-b.github.io/pytest_httpx/"
+SRC_URI="https://github.com/Colin-b/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.17*[${PYTHON_USEDEP}]
+ =dev-python/pytest-6*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest