summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-09 11:41:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-09 11:41:01 +0100
commit7a58deff37cc7d12967dc30f49192d16cd110ee4 (patch)
treeca65be9cbb8367aaf04ffc7525fe5ca12fc7ead9 /dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild
parent4ae313835e5a6ac84a7fd1131b0c51c7a0759626 (diff)
gentoo auto-resync : 09:05:2023 - 11:41:00
Diffstat (limited to 'dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild')
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild
new file mode 100644
index 000000000000..cb8d6dcf63a2
--- /dev/null
+++ b/dev-python/pytest-httpbin/pytest-httpbin-2.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
+HOMEPAGE="
+ https://github.com/kevin1024/pytest-httpbin/
+ https://pypi.org/project/pytest-httpbin/
+"
+SRC_URI="
+ https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/httpbin[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ tests/test_server.py::test_redirect_location_is_https_for_secure_server
+ # minor exception message mismatch on pypy3
+ # https://github.com/kevin1024/pytest-httpbin/issues/77
+ tests/test_server.py::test_dont_crash_on_handshake_timeout
+)
+
+distutils_enable_tests pytest