summaryrefslogtreecommitdiff
path: root/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 13:29:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 13:29:57 +0100
commit4df758340c38fb7f188a6356561aeb4ed2c3f38c (patch)
tree751c69fba382d77b54ca38e9919abd415314405d /dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild
parent4cc852b4016d8aa1fa4d7a8b3911bebe1ed1da50 (diff)
gentoo auto-resync : 08:10:2022 - 13:29:57
Diffstat (limited to 'dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild')
-rw-r--r--dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild
new file mode 100644
index 000000000000..e9ad86f989fc
--- /dev/null
+++ b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2021.12.29-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides a helpers pytest namespace"
+HOMEPAGE="
+ https://github.com/saltstack/pytest-helpers-namespace/
+ https://pypi.org/project/pytest-helpers-namespace/
+"
+SRC_URI="
+ https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_helpers_namespace.plugin
+ epytest -p pytest_forked --forked
+}