summaryrefslogtreecommitdiff
path: root/dev-python/pytest-forked
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pytest-forked
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pytest-forked')
-rw-r--r--dev-python/pytest-forked/Manifest2
-rw-r--r--dev-python/pytest-forked/pytest-forked-0.2.ebuild38
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/pytest-forked/Manifest b/dev-python/pytest-forked/Manifest
index bbdcd99438e4..e31adbab9855 100644
--- a/dev-python/pytest-forked/Manifest
+++ b/dev-python/pytest-forked/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-forked-0.2.tar.gz 9617 BLAKE2B f306c968447b73ddd606f7929b730d222f30640544ff89f6e3e2171ec3b0e98877e0263fea6564d943789de6daa1c344022f001ef80ca37b2467c1b9c360eed7 SHA512 5e84fcaceed46ee9da8eec051e72acb46f09e2df3458511651604c35d68e3ad06fc41d52578127fd29f0c216dcb5fce1844c614f10501727cbf8fa8f2316f231
DIST pytest-forked-1.1.3.tar.gz 7308 BLAKE2B 70711228a5a815de23cbd07b2b628e336a26ccecf420dc9d30d9e9b7ed33bc362b0ba74a8f90fb7cb8dc9e7e0f61d2ac22da55584a84e8ac3a26fcfc2878a802 SHA512 2086884b0e78841b3cdf8eb2b144b8fa60ba95e4be79bc58a2b5775a5f997dddef59377f7c993e54974fbbe13e73fe8688eed4d035e85293e35a143c5f0180f3
-EBUILD pytest-forked-0.2.ebuild 914 BLAKE2B e3acf44f173e4cf5840cf3392796393fbfb61759a7a01fbda29d0805633c5af43777ac99ec87e6c38af7d00afc7ec0c9e5dcac0c75884d52a9c2ebbd823d1cbb SHA512 4dc804fd2609470ff572d9e4288a0f37e83e35e827dfb863362702728c87e6457d68799ecab189502b6b161746b751d85a5936c7682c0b158efda6257a472674
EBUILD pytest-forked-1.1.3.ebuild 810 BLAKE2B fa97cd52cbb338f9180e7df49cb076266a972368aad70b5615f9df8c02d04a82e622cc07c52ecfa11b2bdb56eb70445de0d0d0276e1705d6868862b7d4f38d1b SHA512 b7b9928852ccd3859cff72039d44625acce7f6053da29254b400259b77331e26ab25b6fd077806f0c1697dbe1163fc0518757a34638fe33ee1de4c9871c58eed
MISC metadata.xml 404 BLAKE2B f53cbdb55297b417dc11e904b9bb22d7576ee7df9fa2f5ac80968c31dd9580ffb908bdf1c5ee966b910d8642971410bde39800fb38a01545f5e361f512389a65 SHA512 f6dc614da0c972e76e4ccb2f2141e7da63ac6b6899108b57f3374ec0296652345b97882dab1bf958aaa23046a1070c11889fe3fbc6eecb111bb2bc420620bfff
diff --git a/dev-python/pytest-forked/pytest-forked-0.2.ebuild b/dev-python/pytest-forked/pytest-forked-0.2.ebuild
deleted file mode 100644
index 946da6ffb855..000000000000
--- a/dev-python/pytest-forked/pytest-forked-0.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="run tests in isolated forked subprocesses"
-HOMEPAGE="https://pypi.org/project/pytest-forked/ https://github.com/pytest-dev/pytest-forked"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
-
-DEPEND="
- ${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # remove bundled bytecode
- rm -r testing/__pycache__ || die
-}
-
-python_test() {
- distutils_install_for_testing
- py.test -v || die "Tests failed under ${EPYTHON}"
-}