summaryrefslogtreecommitdiff
path: root/dev-python/pytest-forked/pytest-forked-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/pytest-forked/pytest-forked-1.3.0.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/pytest-forked/pytest-forked-1.3.0.ebuild')
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.3.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pytest-forked/pytest-forked-1.3.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.3.0.ebuild
deleted file mode 100644
index 86bf51f97fc0..000000000000
--- a/dev-python/pytest-forked/pytest-forked-1.3.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="run tests in isolated forked subprocesses"
-HOMEPAGE="https://pypi.org/project/pytest-forked/ https://github.com/pytest-dev/pytest-forked"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Please do not RDEPEND on pytest; this package won't do anything
-# without pytest installed, and there is no reason to force older
-# implementations on pytest.
-RDEPEND="
- dev-python/py[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-3.10[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- distutils_install_for_testing
- pytest -vv -p no:flaky || die "Tests failed under ${EPYTHON}"
-}