summaryrefslogtreecommitdiff
path: root/dev-python/pytest-forked/pytest-forked-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pytest-forked/pytest-forked-1.2.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pytest-forked/pytest-forked-1.2.0.ebuild')
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.2.0.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/pytest-forked/pytest-forked-1.2.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.2.0.ebuild
index d1217706c9c8..c097aaa86906 100644
--- a/dev-python/pytest-forked/pytest-forked-1.2.0.ebuild
+++ b/dev-python/pytest-forked/pytest-forked-1.2.0.ebuild
@@ -14,16 +14,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="
- >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]"
+# Please do not RDEPEND on pytest; this package won't do anything
+# without pytest installed, and there is no reason to force older
+# implementations on pytest.
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]
+ )"
python_test() {
distutils_install_for_testing