summaryrefslogtreecommitdiff
path: root/dev-python/pytest-flake8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-flake8
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-flake8')
-rw-r--r--dev-python/pytest-flake8/Manifest5
-rw-r--r--dev-python/pytest-flake8/metadata.xml16
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild25
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild29
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/pytest-flake8/Manifest b/dev-python/pytest-flake8/Manifest
new file mode 100644
index 000000000000..ff4ffa5bf65e
--- /dev/null
+++ b/dev-python/pytest-flake8/Manifest
@@ -0,0 +1,5 @@
+DIST pytest-flake8-0.8.1.tar.gz 7359 BLAKE2B fd45d50fa68e329569a5964407fae301075907aabf0ec2c85c7ad9b9c28aa7a92acfaf9b7b4e06036c940ca6c7a35388cefb0d9b9151471fe98c968a43cf5a95 SHA512 b49b4d42712040492161f144cce807b661f2d8fe5b484b29ad1a519fd5b0b0cfb6abd42c3ae8999f21263c4776fb773f91bf0776971b6b6727607d33fb49ca89
+DIST pytest-flake8-0.9.1.tar.gz 7959 BLAKE2B d0ef55385dbbf47968abdfc14e69a0420cd52bdf65c0f74ec72abeb1ab28ad27806593dd592f448f3c01dcdf29af4042c1e1c8affde46a1405ba7b4155c174a4 SHA512 eeb4f66022e367d92dee94544ae8fa99b79c1de0579a80e91c22e6f050752010cb7ad6c24094736d23ae753615b186a957b8b0f94c09754005183a971a1e4aa1
+EBUILD pytest-flake8-0.8.1.ebuild 609 BLAKE2B 9decd2d23e8aa8abf54f7aaa0d03a7197720a36200fd2e28ca392db1fffde3180dc165ed09a0bbf936bf2d15bd757c7f6edd37ee2ffd68d11a893bd54baea043 SHA512 8db1450d7d26f0643ef25fb9223eace4f120d33cc026115170d3872110b3ac15154baf4ebdcc50c4a2bd9ed636bc0e8ba6ab0d1ba8bb9114aebd612e88de964e
+EBUILD pytest-flake8-0.9.1.ebuild 675 BLAKE2B e8e99db225150b857fa2049533d77e768a83c8ec9c758468b711beb42283858a1861ba442a0db6383864f25f0207dfc6fbfba8ca0bdf14cba0cc1594f0e0df97 SHA512 8eeb21dd7ecb5484716f8ac89543844b39b7820801f5a1a78195703da5d23e824124bac39c01434e82e81f2223bb9266ef63a24ef993d89cece8d87261b73a4a
+MISC metadata.xml 507 BLAKE2B 75290d0db230e858a4b5b706a2636963a998c882631cd2599bfca3a1961a2f6304dd67b1fa2dbf5a278a86dda00a4c50247f400ff8573845552d3f11b2704595 SHA512 0f022aea078d7eb1b41db5326bf4c1b950344102f4b614ef095e20555a81032687a3312ead75ff33ee8f6dcc81984651dfc110b95113b8c4f2b3e57f52e97baa
diff --git a/dev-python/pytest-flake8/metadata.xml b/dev-python/pytest-flake8/metadata.xml
new file mode 100644
index 000000000000..2ef8e4f36f30
--- /dev/null
+++ b/dev-python/pytest-flake8/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-flake8</remote-id>
+ <remote-id type="github">tholo/pytest-flake8</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild b/dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild
new file mode 100644
index 000000000000..913374116ce9
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-0.8.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for flake8"
+HOMEPAGE="https://github.com/tholo/${PN} https://pypi.org/project/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/flake8-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild b/dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild
new file mode 100644
index 000000000000..9a229ccae918
--- /dev/null
+++ b/dev-python/pytest-flake8/pytest-flake8-0.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin for flake8"
+HOMEPAGE="https://github.com/tholo/${PN} https://pypi.org/project/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/flake8-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pytest -v || die "tests failed with ${EPYTHON}"
+}