summaryrefslogtreecommitdiff
path: root/dev-python/pytest-fixture-config
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-fixture-config
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-fixture-config')
-rw-r--r--dev-python/pytest-fixture-config/Manifest5
-rw-r--r--dev-python/pytest-fixture-config/metadata.xml19
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild33
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.2.2.ebuild32
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pytest-fixture-config/Manifest b/dev-python/pytest-fixture-config/Manifest
new file mode 100644
index 000000000000..5f412ed8673e
--- /dev/null
+++ b/dev-python/pytest-fixture-config/Manifest
@@ -0,0 +1,5 @@
+DIST pytest-fixture-config-1.2.11.tar.gz 6525 BLAKE2B cae41f542fedfcc8587dd5a4cc117480f22fc8abd6f5b85b38451e8199c52d2cb20c4a44fd014504fdc6835be940b4935c95e73dd16cd42049a0e01737a65f6b SHA512 9d335621c7aec41ce769f450fb618ca1611a0e97bf3bd3bdaf43bb827dde62af28fb255a36643c4e6e9c958e7f7efe3f4fc308b3129fe7625c0504c0c46f1518
+DIST pytest-fixture-config-1.2.2.tar.gz 4995 BLAKE2B fee7acb10140320b2ae14968fd99bb11f6c23f54cc86fc74a52855b58071c8deaefb1343c4d92726f7fad5e873c25c426f04d8ced3ecece3d953dee4c7693b7c SHA512 c2d2346c50c8a73e37ce217e240eabdecf872700c9f4b020f1ca7532a06e6a5dc6b140356d96b1bf8c83f1cf737d95775abaa206c3dcf7e02555b26aa995f12d
+EBUILD pytest-fixture-config-1.2.11.ebuild 752 BLAKE2B a1b4f5b11fbe192374bbcaca503ad4e5e4876045b182f408e2f43d0ebb5862fe1b278c719a803fcf68050ac20b122790396dbf2842068541c228ac83dc75f049 SHA512 fc745e6f270bb1a8e767dd3aabdd24a5ee1829ffc52a2a09d1d010511cda2b232e7ad422aad7815888da94a37c22bce3b1a80a945f55501dc99552027f8c7c90
+EBUILD pytest-fixture-config-1.2.2.ebuild 704 BLAKE2B 3af1cf4112f040be56782ab80a28c979efd1cb239625ec353e1dc686c25c9ede55f474a2594863fa9fbb2f36eaaeb1ba7b255f15c58ea504ec054de7a38aacfe SHA512 a56a05d20304efc43657e640a2f4d51cbd5ffa93338290b3a5786883833e133f551857a01d05f356378277fb12bc35a2fdce59c7bfc0ad6af53cc0a4dbf278c4
+MISC metadata.xml 628 BLAKE2B 925ae819fcb1ec9d45dd67640954152313f84eab26d5ee055d8589e29062ee275f61f828dec879fded534bd3db0c89580fbe6e16b5ebca4c2f5547bbbeaf365f SHA512 a11640b82dcc479a13ab8eed44d7a543e8594c6f829ef64855d02a750ce605181e6503d5d8dc2d95c8740fb70f86e0c95467d9df81b7bd2702e3658572035af6
diff --git a/dev-python/pytest-fixture-config/metadata.xml b/dev-python/pytest-fixture-config/metadata.xml
new file mode 100644
index 000000000000..bd0708f058d9
--- /dev/null
+++ b/dev-python/pytest-fixture-config/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>eeaston@gmail.com</email>
+ <name>Edward Easton</name>
+ </maintainer>
+ <remote-id type="pypi">pytest-fixture-config</remote-id>
+ <remote-id type="github">manahl/pytest-plugins</remote-id>
+ </upstream>
+ <longdescription>
+ Simple configuration objects for Py.test fixtures. Allows you to skip
+ tests when their required config variables aren't set.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
new file mode 100644
index 000000000000..b8031b9b891a
--- /dev/null
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.org/project/pytest-fixture-config/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.2.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.2.ebuild
new file mode 100644
index 000000000000..524b88b962a8
--- /dev/null
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.org/project/pytest-fixture-config/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/six[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}