summaryrefslogtreecommitdiff
path: root/dev-python/pytest-fixture-config
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-fixture-config
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-fixture-config')
-rw-r--r--dev-python/pytest-fixture-config/Manifest5
-rw-r--r--dev-python/pytest-fixture-config/metadata.xml20
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild33
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.2.2.ebuild32
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/pytest-fixture-config/Manifest b/dev-python/pytest-fixture-config/Manifest
new file mode 100644
index 000000000000..274e27dc99b1
--- /dev/null
+++ b/dev-python/pytest-fixture-config/Manifest
@@ -0,0 +1,5 @@
+DIST pytest-fixture-config-1.2.11.tar.gz 6525 SHA256 6d4c064b614e4afbcd93b56d4ca14c44a295370e7843daf69925ff5c0fbe94a0 SHA512 9d335621c7aec41ce769f450fb618ca1611a0e97bf3bd3bdaf43bb827dde62af28fb255a36643c4e6e9c958e7f7efe3f4fc308b3129fe7625c0504c0c46f1518 WHIRLPOOL 9386794f00575efbc06fcf212f132cf11a91df942e5807ecaad7651b67298dad577a8831450ae462c185732101262278e92a208f08fd11af2d15ae3664290485
+DIST pytest-fixture-config-1.2.2.tar.gz 4995 SHA256 5df71da68709a233a7a9f1aa262091ac17ddfd4c170912d07030801fd360b781 SHA512 c2d2346c50c8a73e37ce217e240eabdecf872700c9f4b020f1ca7532a06e6a5dc6b140356d96b1bf8c83f1cf737d95775abaa206c3dcf7e02555b26aa995f12d WHIRLPOOL 97488a31b1b39f5964df34900e4ff8209e425746a7791172cdc6804c98561fa73a7d28d668bbea4fa55082d81c07a50387891a60c8503eedd761bc8f9639673d
+EBUILD pytest-fixture-config-1.2.11.ebuild 710 SHA256 3c37ad0898b72fce5319fe037048c43819d8c1a5eedbf0150320de1af346c523 SHA512 df62a566209db25b36156ed81c4d0ca3c59da6d3754f194b4fba74c6d74ee295021393585ef051eec6084fdfe20e19d5bee7444863733931a6975975082bc515 WHIRLPOOL 8e548b07ad385dcce5f18f2dd535626fb9db07536db3f86fd0b1302699c4407c7d9f01b525a755cd13a432ff28fb51b1b25b63278e7f04efe34ea9a95c20d58b
+EBUILD pytest-fixture-config-1.2.2.ebuild 707 SHA256 f06b2a6a6f5baec8656414c70322c18af28e992f55af73c05b548ab6c80be7f0 SHA512 e1554212104ddce7d35730af725f612cf646e469b7f154e5af843d555c4e3e8d45d3081a413b4db69deb11f124503d2a4ba75820a7a2cfdb804c2bea23068316 WHIRLPOOL 06a0559364b99a6559e4cf203e5c29655400cf1e821700304ece3365cbc1025e33be514d443ce70dcc30c3ca50e56a11d6c475ea77acbf1bc08ca15354528c58
+MISC metadata.xml 676 SHA256 5d1567ee96b545d501cdb9ca9f1bd24f637a36823c7332b8ee517fcb73ee22a0 SHA512 9e4cc39afad13c0cdce47c59c42c4d71436422d37d4f113a446238036b1f05d38eb8fa6d53b9001ca630483492dd315090062efe221339e63776f126d964620d WHIRLPOOL 73700ae50cf2e7800f17ef6ac85f1c8840d8bd3251bd891b2d658ad5913ba09c57ee0e6e2dc3401a3ea7bc79f4f568895d2595fc2a2dbd11310f0ee54eb6cfeb
diff --git a/dev-python/pytest-fixture-config/metadata.xml b/dev-python/pytest-fixture-config/metadata.xml
new file mode 100644
index 000000000000..6aebd3d199bb
--- /dev/null
+++ b/dev-python/pytest-fixture-config/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>eeaston@gmail.com</email>
+ <name>Edward Easton</name>
+ </maintainer>
+ <remote-id type="pypi">pytest-fixture-config</remote-id>
+ <remote-id type="github">manahl/pytest-plugins</remote-id>
+ </upstream>
+ <longdescription>
+ Simple configuration objects for Py.test fixtures. Allows you to skip
+ tests when their required config variables aren't set.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
new file mode 100644
index 000000000000..b5fc191522f5
--- /dev/null
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-fixture-config"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.2.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.2.ebuild
new file mode 100644
index 000000000000..89bdb6e1b147
--- /dev/null
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-fixture-config"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/six[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ distutils_install_for_testing
+
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}