summaryrefslogtreecommitdiff
path: root/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild')
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild
new file mode 100644
index 000000000000..040b3f90b5c2
--- /dev/null
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="
+ https://github.com/man-group/pytest-plugins/
+ https://pypi.org/project/pytest-fixture-config/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# block pytest plugins that will be broken by the upgrade
+RDEPEND+="
+ !<dev-python/pytest-virtualenv-1.7.0-r1[python_targets_python2_7(-)]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest