summaryrefslogtreecommitdiff
path: root/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild')
-rw-r--r--dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
new file mode 100644
index 000000000000..b5fc191522f5
--- /dev/null
+++ b/dev-python/pytest-fixture-config/pytest-fixture-config-1.2.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.python.org/pypi/pytest-fixture-config"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}