summaryrefslogtreecommitdiff
path: root/dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild')
-rw-r--r--dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild b/dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..a6b8fa81adda
--- /dev/null
+++ b/dev-python/pytest-expect/pytest-expect-1.1.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that stores test expectations by saving the set of failing tests"
+HOMEPAGE="
+ https://github.com/gsnedders/pytest-expect/
+ https://pypi.org/project/pytest-expect/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+# no tests
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/u-msgpack-python[${PYTHON_USEDEP}]
+"