summaryrefslogtreecommitdiff
path: root/dev-python/pytest-env/pytest-env-1.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-28 10:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-28 10:54:09 +0000
commit3e690338421a6b64f6f44aa03db7416d75e0633a (patch)
treecb3907b4dfbc040edc539fd00645e851b14084bb /dev-python/pytest-env/pytest-env-1.1.3.ebuild
parenta6f8a4117d60ec2919f9b312dcb0b7baa6c58ab9 (diff)
gentoo auto-resync : 28:11:2023 - 10:54:09
Diffstat (limited to 'dev-python/pytest-env/pytest-env-1.1.3.ebuild')
-rw-r--r--dev-python/pytest-env/pytest-env-1.1.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-env/pytest-env-1.1.3.ebuild b/dev-python/pytest-env/pytest-env-1.1.3.ebuild
new file mode 100644
index 000000000000..407864cef54b
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-1.1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows you to add environment variables"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-env/
+ https://pypi.org/project/pytest-env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}