summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/pytest-django
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest4
-rw-r--r--dev-python/pytest-django/pytest-django-2.9.1.ebuild37
-rw-r--r--dev-python/pytest-django/pytest-django-3.4.4.ebuild26
3 files changed, 28 insertions, 39 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index f45d124c9254..f25d9aa38e0b 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,3 +1,3 @@
-DIST pytest-django-2.9.1.tar.gz 50570 BLAKE2B f709ba00e16686cc2c7b3db168e775e8fcbebdb8ed732882d53c6c377d957af220b63dbe48120850de0773021f448270d855635336d08b6914edaa8c877c18bd SHA512 0e50f45a0cfefb6fa74f7d60d5173e3e8dac49ac669c9c88e46d27a01cff5c4a255d6f707863406b6f8707e25e9bea3408cbffbb75a2680fee365b9c9167d468
-EBUILD pytest-django-2.9.1.ebuild 927 BLAKE2B e40b384be5874629749c476e1a893266796b4d030dc1369416db92755a33867b113ae53db6b7490c4faa9c6e4f698f38e783cc4ff47ce746ceae9df8e6e2f9b3 SHA512 f2eaed773ecc4a287dea27ab6220f266d6b4c9d61e68c0886049027f0a93fa6cccc05bc19089a2c5413f95f77be2a089add9935cb2fbc670932aa17818d6391d
+DIST pytest-django-3.4.4.tar.gz 66962 BLAKE2B a989009eccab4bbd96e32ed1b6b5d03ca8105026c6d9219ea09f6b33fe2087a30d9042e2cd5a313196ed67cc1c5dc940d04fe981dda0da4f25cf16a43e88471a SHA512 a851b27e9abc4829a47abb5da40cbd69fea5c48b05c81f88910d4345696c6d01f78e07ac489cec7cfb5724dd8432891ff9260dc585e720d758491906812661df
+EBUILD pytest-django-3.4.4.ebuild 713 BLAKE2B c3cc2889003f27da85164b7c670e9a139f78f44b7900fd727d1a4963d9fde1e9934620936d5b54e28fabe239776f3c06968bd6fbd6622a41585458e8de9b7ee9 SHA512 caef6bd41673d293ff67435dd4d353b4d2fd0ce9acd7fce81ad145882f51cf65afa408342576756b6346e489e8659bcee20cd085af24348a583995e2e1185f44
MISC metadata.xml 380 BLAKE2B 6d349594a1198f6cbf2c6e0e80276f3d27454346cdbd24654506221647304fc3d3a0c9b8deadb920c4881b62c779951df2cda6a773f4f251c7c31d166fdf7b2c SHA512 65163d6f99c4d2be86bbedad07b756eda2aa639cd612e0ffaf95dc0707e72de8b406ad51d2a482925790c837bc7c3d4ccd5dc3fd070da6599e13278db03ab006
diff --git a/dev-python/pytest-django/pytest-django-2.9.1.ebuild b/dev-python/pytest-django/pytest-django-2.9.1.ebuild
deleted file mode 100644
index ecfe25826b50..000000000000
--- a/dev-python/pytest-django/pytest-django-2.9.1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Django plugin for py.test"
-HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.8.0[${PYTHON_USEDEP}]
-"
-
-# https://github.com/pytest-dev/pytest-django/issues/290
-RESTRICT=test
-
-src_prepare() {
- sed \
- -e '/setuptools_scm/s:==1.8.0::g' \
- -i setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- PYTEST_PLUGINS=${PN/-/_} \
- py.test --ds=pytest_django_test.settings_sqlite_file --strict -r fEsxXw || die
-}
diff --git a/dev-python/pytest-django/pytest-django-3.4.4.ebuild b/dev-python/pytest-django/pytest-django-3.4.4.ebuild
new file mode 100644
index 000000000000..8bf3d8318118
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-3.4.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="https://pypi.org/project/pytest-django/ https://pytest-django.readthedocs.org https://github.com/pytest-dev/pytest-django"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"