summaryrefslogtreecommitdiff
path: root/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
commit1426dfeb15e4d49cb4238c6cf37455a6130cd83f (patch)
tree9f9734bcdc280108e52d753b3c57234371772c3c /dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild
parent836586553c510ee2dd91e2ecd7676fe432c1f1a4 (diff)
gentoo auto-resync : 18:09:2023 - 11:05:42
Diffstat (limited to 'dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild')
-rw-r--r--dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild b/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild
new file mode 100644
index 000000000000..b11ae43d789e
--- /dev/null
+++ b/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="
+ https://github.com/nschloe/pytest-codeblocks/
+ https://pypi.org/project/pytest_codeblocks/
+"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytester
+}