summaryrefslogtreecommitdiff
path: root/dev-python/pytest-codeblocks/pytest-codeblocks-0.16.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pytest-codeblocks/pytest-codeblocks-0.16.1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pytest-codeblocks/pytest-codeblocks-0.16.1.ebuild')
-rw-r--r--dev-python/pytest-codeblocks/pytest-codeblocks-0.16.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-codeblocks/pytest-codeblocks-0.16.1.ebuild b/dev-python/pytest-codeblocks/pytest-codeblocks-0.16.1.ebuild
new file mode 100644
index 000000000000..eee40482f02e
--- /dev/null
+++ b/dev-python/pytest-codeblocks/pytest-codeblocks-0.16.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="
+ https://github.com/nschloe/pytest-codeblocks/
+ https://pypi.org/project/pytest_codeblocks/
+"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytester
+}