summaryrefslogtreecommitdiff
path: root/dev-python/pytest-check/pytest-check-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-19 08:07:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-19 08:07:42 +0000
commit0184387f6a748c74c5d29cddf20289dc94f05ddc (patch)
tree254558423398a56afd082c6d0b4e60341ba38adb /dev-python/pytest-check/pytest-check-2.3.1.ebuild
parentf432b083b2efe1e2aa0a7497bf0ca78eeb483332 (diff)
gentoo auto-resync : 19:01:2024 - 08:07:41
Diffstat (limited to 'dev-python/pytest-check/pytest-check-2.3.1.ebuild')
-rw-r--r--dev-python/pytest-check/pytest-check-2.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-check/pytest-check-2.3.1.ebuild b/dev-python/pytest-check/pytest-check-2.3.1.ebuild
new file mode 100644
index 000000000000..19b540aee910
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-2.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest