summaryrefslogtreecommitdiff
path: root/dev-python/pytest-check/pytest-check-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-26 13:14:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-26 13:14:43 +0000
commit7de40ae3e1ba40671bc9aac9ebbf3f42952a036b (patch)
tree1bca877e82a542b8d0809d9de07a59ae67941c07 /dev-python/pytest-check/pytest-check-1.2.0.ebuild
parentfd3ff6e6efb0d3cf8b899956e7b48df4e2ac9615 (diff)
gentoo auto-resync : 26:11:2022 - 13:14:42
Diffstat (limited to 'dev-python/pytest-check/pytest-check-1.2.0.ebuild')
-rw-r--r--dev-python/pytest-check/pytest-check-1.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-check/pytest-check-1.2.0.ebuild b/dev-python/pytest-check/pytest-check-1.2.0.ebuild
new file mode 100644
index 000000000000..9a459557d506
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest-check/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest