summaryrefslogtreecommitdiff
path: root/dev-python/pytest-check/pytest-check-1.0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-26 02:51:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-26 02:51:21 +0100
commitea6ec22f536553dcd417bc8b577418d3ebe5ce4c (patch)
tree318c03426d27d596f62898b46d48f5f6af2b070e /dev-python/pytest-check/pytest-check-1.0.9.ebuild
parent1ab3970274a99b42f555ca7959efe9ace063abd5 (diff)
gentoo auto-resync : 26:08:2022 - 02:51:21
Diffstat (limited to 'dev-python/pytest-check/pytest-check-1.0.9.ebuild')
-rw-r--r--dev-python/pytest-check/pytest-check-1.0.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-check/pytest-check-1.0.9.ebuild b/dev-python/pytest-check/pytest-check-1.0.9.ebuild
new file mode 100644
index 000000000000..31947e866cc2
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-1.0.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest_check/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Fix expecting result in case pytest throws deprecation warnings
+ sed -e '/fnmatch_lines/s/\* /\*/g' \
+ -e '/fnmatch_lines/s/ \*/\*/g' \
+ -i tests/test_check.py || die
+
+ distutils-r1_src_prepare
+}