summaryrefslogtreecommitdiff
path: root/dev-python/pytest-check/pytest-check-1.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 23:34:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 23:34:28 +0100
commit5b14ea000f5782ac047162ffc35ef8c3c0648b4a (patch)
tree9bd4130367f85e9308e6d6c6b12ba58759b5f789 /dev-python/pytest-check/pytest-check-1.0.7.ebuild
parent85261a4d217482e1c124937d57ec98a0aabaee59 (diff)
gentoo auto-resync : 25:09:2022 - 23:34:28
Diffstat (limited to 'dev-python/pytest-check/pytest-check-1.0.7.ebuild')
-rw-r--r--dev-python/pytest-check/pytest-check-1.0.7.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/pytest-check/pytest-check-1.0.7.ebuild b/dev-python/pytest-check/pytest-check-1.0.7.ebuild
deleted file mode 100644
index 31947e866cc2..000000000000
--- a/dev-python/pytest-check/pytest-check-1.0.7.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="pytest plugin that allows multiple failures per test"
-HOMEPAGE="
- https://github.com/okken/pytest-check/
- https://pypi.org/project/pytest_check/
-"
-SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/pytest[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # Fix expecting result in case pytest throws deprecation warnings
- sed -e '/fnmatch_lines/s/\* /\*/g' \
- -e '/fnmatch_lines/s/ \*/\*/g' \
- -i tests/test_check.py || die
-
- distutils-r1_src_prepare
-}