summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-cache
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-cache')
-rw-r--r--dev-python/pytest-cache/Manifest4
-rw-r--r--dev-python/pytest-cache/metadata.xml13
-rw-r--r--dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild30
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-cache/Manifest b/dev-python/pytest-cache/Manifest
new file mode 100644
index 000000000000..09a8cdb676a2
--- /dev/null
+++ b/dev-python/pytest-cache/Manifest
@@ -0,0 +1,4 @@
+DIST pytest-cache-1.0.tar.gz 16242 SHA256 be7468edd4d3d83f1e844959fd6e3fd28e77a481440a7118d430130ea31b07a9 SHA512 55eb66718a45fb0ad8931780d96fa4715cf0d9f2568be2a1b08b3399d391b818a7ae8b2afeb74b50aaf8ec8f7f0d8da8e7a7483845a50e884822ca6ddbca03ea WHIRLPOOL f1610e5ae8505abc6f6175d029c5afb9e3fbc7d10ba31379305752ebd941209514a054e34d36c794270d4a9eb0001c71aeea9700431798f54a1b40013a3d77a2
+EBUILD pytest-cache-1.0-r1.ebuild 875 SHA256 d118d30c58129c22667f156ba5f8676fe602e628447a2ba7f0cb0a6d46485da2 SHA512 7da2dde5722ab93ee3859c5a70edae4aa9c1f58749937d9653d334c1d0f23e37044cd85446c6116eade26d44745f12b20c5ccb5a7c4c000813d43d9dd0d76ae5 WHIRLPOOL 96153bd5844175eb91ca449eaafd2f3ccd50c9f4c72ac938c796281bcd16cc626804127cf06c605cf0c24bfee904b7e17e1cfd22878199fc743f6b696512bf39
+MISC ChangeLog 1808 SHA256 bc9a90ea3bec3a38123b149ffb88813018346e3bf8824ee8cf3e481704a8f9eb SHA512 ecdf467fc2b3cdbd0db27e931eae959fdaee17b895fc1277de1db7e97a19f70a58948b3ee826685aaf8cd62a667b2e3a0c6838389f0d931bb81d59df71cefc36 WHIRLPOOL be3d03207a3ea2e254d17a20084f1bd6047a2b98179d5076f61ea709ed638a32d08168ce33ee9118b1aa6a40defc5da5aa5eb266a07d4105f57689c7703a9e3b
+MISC metadata.xml 424 SHA256 833f0765f05561d91b07415a704f0083913eee3de98cdd15160ab9b9638acff0 SHA512 d5cacf7c2874eec32bd10036f6fa03f0d357569e99b229b397df2ca1978f3961b9f3e7cd892cba677e4f6c4e39a5d69ef496166285adf089e08e7406446c9a35 WHIRLPOOL 87b3825d816ba0649df6b28f06311c326d25dcd93e230a1a49a32468eea1613f37695a64c5c491b5097d0ff178cc0eda1ce69dec947b2ff5294e7d9be968494f
diff --git a/dev-python/pytest-cache/metadata.xml b/dev-python/pytest-cache/metadata.xml
new file mode 100644
index 000000000000..c84b16d0098e
--- /dev/null
+++ b/dev-python/pytest-cache/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pxml</remote-id>
+ <remote-id type="github">metagriffin/pxml</remote-id>
+ <remote-id type="bitbucket">hpk42/pytest-cache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild b/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild
new file mode 100644
index 000000000000..ecb5f90c44be
--- /dev/null
+++ b/dev-python/pytest-cache/pytest-cache-1.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="mechanisms for caching across test runs"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-cache http://bitbucket.org/hpk42/pytest-cache/ http://pythonhosted.org/pytest-cache/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/execnet[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+# https://bitbucket.org/hpk42/pytest-cache/issues/12
+RESTRICT=test
+
+python_test() {
+ PYTEST_PLUGINS="pytest_cache" py.test -v -v || die
+}