summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-05 21:18:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-05 21:18:38 +0000
commitca3d7bcb3126761ac24ef4642964d7e16b1df428 (patch)
treee1e7daaca6abe9ca218985bc106bc2642a03e1ea /dev-python/pytest-bdd
parentc66fa6cf106b825bcc6f1beeff9486ff08232cbe (diff)
gentoo auto-resync : 05:11:2022 - 21:18:38
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest2
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-6.1.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 1dc5c0a88595..d34dce2df41c 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,3 +1,5 @@
DIST pytest-bdd-6.0.1.gh.tar.gz 60932 BLAKE2B 67e0dbc251ce94da40033641f37e6c9ad70ca947f71db1a78907a6890d96d8d3112d57a2a63dda526c8f846010d39a575cb5d93a102f4653705d4229ee14ab07 SHA512 30bc697ae177e3f311af0c781e99bde5b491dfef28109359c0d80f33feb8b0b170ffe15c288fe73a624144a1d1c3223b220d591b4acc30d1ad53600482bef87d
+DIST pytest-bdd-6.1.0.gh.tar.gz 79270 BLAKE2B 145d1adc6dae8098b30bfd68ce78dcf3c0b6626a32f8da05805f78f176111dd367a62e76eb61d520391c88bf9eda234f63d983bcfa36f00d39d85a026c78f883 SHA512 957b39a9c7c48b8d5e42d301de875579d062744766c55ffa32aed78a5a8a5c9fd9bb3ba281183841bc1da19604659c94ecaa4487dfc7a6dd69b507f5fc9f2dc7
EBUILD pytest-bdd-6.0.1.ebuild 1084 BLAKE2B baa7bbb71d57683cb4b03dc4fb15ffb510d214df05fdf714767767a73846b6543188ab4af6b931db3c3362cad3b945e271979837f1168a04dcb32c9acdf06549 SHA512 2df002e33e225db79ddb3f6afc9c70e7d1d6f0ef29aad3c8f44189cb9b86faa430053dcba31c3ddb2ce6f8ba5367873d61688b0cc6ffc3208af49868eb566118
+EBUILD pytest-bdd-6.1.0.ebuild 1012 BLAKE2B 8e35ca6650469bd1e9405cac2b134cbf2dbc9fc89343840e6ff0b38aba5f6cfede418a055424bce54bb640c43202dd4cf1666cb2c175751decd86372e5a15e7c SHA512 4307a29333661ac4960ef2d355b643b16716e0fed85584d5c6d126cbbcd1fdd3401d42419207b193db90163619101cfaacc71b8e19d0b8ec7dc509d95c3bca32
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-6.1.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-6.1.0.ebuild
new file mode 100644
index 000000000000..a8fc183a60ad
--- /dev/null
+++ b/dev-python/pytest-bdd/pytest-bdd-6.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="BDD library for the pytest runner"
+HOMEPAGE="https://pypi.org/project/pytest-bdd/"
+SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/parse_type[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/packaging[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.rst CHANGES.rst README.rst )
+
+src_test() {
+ # terminal_reporter test needs exact wrapping
+ local -x COLUMNS=80
+
+ # hooks output parsing may be affected by other pytest-*, e.g. tornasync
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_bdd.plugin
+
+ distutils-r1_src_test
+}