summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-08 18:59:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-08 18:59:30 +0000
commit1e1e7636b59380beebd325e8d256875e4f824230 (patch)
treecac3706b236cea47f66f8d45afc943890cd4375e /dev-python/pytest-bdd
parent5cbf14acf23c82626389931f64cfe3ef12a1c29f (diff)
gentoo auto-resync : 08:01:2024 - 18:59:30
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest2
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-7.0.0.ebuild48
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index 5efdb2653b76..095e0f9dff4f 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-bdd-7.0.0.gh.tar.gz 80196 BLAKE2B cb34f5439959e93ccb68c566e284d1789a183dd85c1c3088d0c929373e88bd994de2ac159ea942119183976e64903cf7ca8f2b2137aad749f8b67728c541ee89 SHA512 0f95334a56ff7ccc774e5b94b91d232b829fb308a21ce975c88720493abbefa9e76fcd35cc2ca9bbbf0fd2e38b6f20f5be6cf59368aab4cf70abdaf24c7fd5ed
DIST pytest-bdd-7.0.1.gh.tar.gz 80315 BLAKE2B 7838a71fc6f0e7a86337d3b4d4fb9e0e7a3a0149c4271ecd75b5c9b40a28ad6bf3d6ccbc90d4a49a5472ae158f7710d98f91be340e67995ba47ea729584d16e5 SHA512 60d9713485a4719c6589e6641b45045e79c063278359c14ccbd016a6b0a8c8eebbf93e61d59e037988247c0116023910aa5e6776896b64dc96dcc23d0dbf6e3b
-EBUILD pytest-bdd-7.0.0.ebuild 1111 BLAKE2B f43979c6d9965cb62c3f9ca0ebb458c39a5ebede55e4cde4d6bc6e851645266ce65f1701eb1bec8c9bd2bdbf63928d34b011f100adb392da4de767f4bc1cfc6c SHA512 a770fd47d7a0da66271cf3838edf9e960901b460fb6d40ccd1d0312fa53efd646af010eb60202792fcd7fcb8d77cf8a0175bc506c6f7b58ec688a6b855ff4b99
EBUILD pytest-bdd-7.0.1.ebuild 1111 BLAKE2B f43979c6d9965cb62c3f9ca0ebb458c39a5ebede55e4cde4d6bc6e851645266ce65f1701eb1bec8c9bd2bdbf63928d34b011f100adb392da4de767f4bc1cfc6c SHA512 a770fd47d7a0da66271cf3838edf9e960901b460fb6d40ccd1d0312fa53efd646af010eb60202792fcd7fcb8d77cf8a0175bc506c6f7b58ec688a6b855ff4b99
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-7.0.0.ebuild b/dev-python/pytest-bdd/pytest-bdd-7.0.0.ebuild
deleted file mode 100644
index bc6223fab65a..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-7.0.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pytest-bdd.readthedocs.io/"
-SRC_URI="
- https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~x86"
-
-RDEPEND="
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}