summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pytest-asyncio
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.16.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 15ec0954d88f..a1da6adc9835 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,4 +1,6 @@
AUX pytest-asyncio-0.15.1-310-test-warnings.patch 297 BLAKE2B c8144f2ac331d5bd0bd793a1f66b6dda89e2a8c5e027c92e73806d111d144c70fce4adb044a65f7f0ec8e540e673562f608111a21ddef691a7275fdde3bb0cf3 SHA512 aca66133f76031b7ac7e6daae427184cf6e480fc8b66324751eecfd968073d8e3302cdaa978293f9459d6233c6503483e699b98d0addc53b7c1c36dd31c2e7bb
DIST pytest-asyncio-0.15.1.tar.gz 15653 BLAKE2B 8f10c46672a18d6992248482f9e3eb68ca9d3bae5163d5924e6363a15bc97dbfdc8b9dfc21a8a89ee4a6e21d76b083b1aa5a077fe581f0f2f0bd4c5a7b519cc9 SHA512 1813d49e0dd55f563d9bf058e009da61a17f61e081cc53626b5f1db623ba04905b6bea3ecba423dc931668053310176b634339d6526c7ea729d9aad87e4f044d
+DIST pytest-asyncio-0.16.0.tar.gz 15819 BLAKE2B c999b8680a45704bcb6f4690a910aa3d2edd9965e53cf4eb59dc8119696add4553d6b3e1b010c3cac52c8fd8563be8c86afe0616132a274e73df673630b032a7 SHA512 f0059a6d05bf0c4e208f0058e30d5baf8284e630b8b91fa217f52eec18abe6b057dabfdadce2c5282e02bd4ea4cdb27f9ef62c4c308375cce1795d75a036db22
EBUILD pytest-asyncio-0.15.1.ebuild 772 BLAKE2B 7a74f9dfdc9fc582c7eb8283ee7af2c655021dce0886d3ee629fa4d024a998f575247f27657dab57f28730a45485f063d040165816887d463b956623518d6a92 SHA512 6c0b1ba3cf825df35dc89f391d942ea0bdf95719b8d9322dd670700b8009a4cdb39419b7d19d2e328970603ce358fe7fc2e56a02572d1f5af2811e4672569b8a
+EBUILD pytest-asyncio-0.16.0.ebuild 723 BLAKE2B 67b117d99f72235de2aa4bb110ab59de226c16ec02e00a9f457364ba04f5b482c9cef1dc245f75c5bc51abfb5332194ba4ae86e0613184ecb993af84ceb8dd18 SHA512 7b5d599ac9e98e2e8ce9cefa5a94a752dddaa462ffee6c54cb7f2c4c1f30185a0ea22612f5d6269f9050a93fdb00c338a79e06b67c68120d3b3b8cb472627bf1
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.16.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.16.0.ebuild
new file mode 100644
index 000000000000..c6de120f92c7
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.16.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest