summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-18 12:29:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-18 12:29:02 +0100
commitf85858c81a721c7fc89c1ab8df19e3a213dc27cd (patch)
tree3f0aeb33e434ee50b99bcc8b54158bc6169a41f2 /dev-python/pytest-asyncio
parent16857b69f990738d17bc5842e3e49a6e82d1428d (diff)
gentoo auto-resync : 18:07:2024 - 12:29:01
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.23.8.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index fbae3dd0e9e5..3caf04452691 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,5 @@
DIST pytest_asyncio-0.23.7.tar.gz 46296 BLAKE2B afcdba0928f07e91ed68f54de2c1241fec784f164e3d5edb09908b913536edadbba7c90a73a8c843715da4567b18cc27929f31c6d0c2be3940e6ecc23abcc43c SHA512 d7164b060c1d0aa7999537e5681d2153662d49ec94e056da93b4cb2ba3dd0e3e5e4a68691c15b920c8e0ced03a4256620da600a33bcfa76b1adfa7ee66cd8de0
+DIST pytest_asyncio-0.23.8.tar.gz 46920 BLAKE2B 6b7a66e6ef28f2c7a874a115e0346b3803051df5d57e5b8ba35480982231a804adfbe8a4a2c605847730ea940fafe9df2aa94f5081b43aa753b64c3e2ea027a5 SHA512 68f23458c5f22bdb75a6a0a12f185b1f22c5231c0cdcd84806781419f5c866844e851398d771c5932af4a42b5dfdcce6624181f2c0d2f70187bb5feed0ba7c97
EBUILD pytest-asyncio-0.23.7.ebuild 1585 BLAKE2B 1e2e0920696b7c6f42b5512c066c031c9b414b07d38f8f3f8cc8ae968c1fb6c6b75a55a985397e76c0562bbc2d8e7f13fb7d3777d48f19851731d618a5c0c26c SHA512 d2ef6709cf1d74350e0368ff320b1c6a31e7815b08c81cb2b8239d67115c70c9bea6c1082ec6c20107909cfdab0874a125d9add94e08f23079af2f669c9ea55e
+EBUILD pytest-asyncio-0.23.8.ebuild 1593 BLAKE2B d6f54d0b041123f4f5f2b52e92bbeaa2f21ddb28955fc748cfe8fcb6d2be0c796b0e08ee4c4089ba81f0fae1a1635c8987b27980095786ead69728f955246cc7 SHA512 b3379d24765c15f24796056c7a8d121fcca3012356472a8ffb878dd42f9f79f339599b4f9e2264ee3614693e079b82b2ecab5e48078948de633e37beb18cea80
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.23.8.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.23.8.ebuild
new file mode 100644
index 000000000000..ccbee1a2f1c6
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.23.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
+ tests/modes/test_legacy_mode.py
+ tests/modes/test_strict_mode.py::test_strict_mode_ignores_unmarked_fixture
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
+ tests/test_pytest_min_version_warning.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+
+ # TODO
+ tests/test_is_async_test.py::test_returns_false_for_unmarked_coroutine_item_in_strict_mode
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
+ epytest
+}