summaryrefslogtreecommitdiff
path: root/dev-python/pytables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/pytables
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/pytables')
-rw-r--r--dev-python/pytables/Manifest2
-rw-r--r--dev-python/pytables/pytables-3.6.1.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/pytables/Manifest b/dev-python/pytables/Manifest
index c26ee52f47e7..26ea4d44d095 100644
--- a/dev-python/pytables/Manifest
+++ b/dev-python/pytables/Manifest
@@ -1,3 +1,5 @@
DIST tables-3.4.4.tar.gz 4626053 BLAKE2B cca4f87aa62db16bb47e131bf670e1013d363dea9c807f399688e184610f682c49b00b686d8e28a03caf94a98e51b11bf646df66f4e3db66f481751f096906f8 SHA512 2d0cdd36a6f14702f424773b64187d1980d73a72525ead43b272776bb32b2ebc4c6ea0b7e3343c8600d7f62c42d008b5e835439af30e76ea11c7504666631ddf
+DIST tables-3.6.1.tar.gz 4641089 BLAKE2B 4ef44b1263f40babe6719bac911ab191e9cb0c58c377705b755fa83f1fba5af1d0fab10b0b45bd6af619a9dce4842a80afad8d8fbab64c3be4f35a1b3f117ee3 SHA512 7f018b70251095049bce9075be4e19f72efba9d39121a35c4521f634b1dd5b81ab6de47df3bb44ad6b8b2dbdbff4e6d0985ad1a7b2f13b44f920c0935e5830ff
EBUILD pytables-3.4.4.ebuild 1734 BLAKE2B 0b9d317bd8a6074c7770f29fbfa8b10bb8bb7b7925cdf95eacca691449070f8a6fffcdd4e7d4258212b58291631aef89070c4b044ebb07bc62540b430969f266 SHA512 8c2383039512ad9ecbbff0e0eaf986dd2bca5781534ed6cd4d4c8ed63072664220adabb3bbe08b6a8ce9d272d92689b37d44d78eadac28ec0fc018dd65c8c1c2
+EBUILD pytables-3.6.1.ebuild 1737 BLAKE2B 9499f51855bd35998865af1439b803eac86c09936faddf3ec4059d6f3475a518043c3b817d6ba1dead77aa508d09203df219ef0367f62aa165224c7d6c638d27 SHA512 f0b2f951d189bb5d62d87fb754a525b5f4047eac1ea41ecdd020b20323be941e0073901df960eddec9c98bfff31e09c328b1744b0807eea386490a74e090fdb4
MISC metadata.xml 894 BLAKE2B 279b64a5124a6471b3ea6ed8d2f82b8d62e5d8bc809168fb2ae1c3bfd8cfa07428c2ff7f07deb5042a6ccb5ba7af43bc45d0db82b9cfc79fa5d19c090d0500a3 SHA512 88dd752e6014f6f133b5df7db6c2aafce0b9da8cdbc057493916dbfbe1da4bf52e0ed43d570d68035fc8f12302794a381a54f5b07b9726b52601724163bc672c
diff --git a/dev-python/pytables/pytables-3.6.1.ebuild b/dev-python/pytables/pytables-3.6.1.ebuild
new file mode 100644
index 000000000000..abe2b97d2fe5
--- /dev/null
+++ b/dev-python/pytables/pytables-3.6.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+MY_PN=tables
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Hierarchical datasets for Python"
+HOMEPAGE="https://www.pytables.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/bzip2:0=
+ app-arch/lz4:0=
+ >=app-arch/zstd-1.0.0:=
+ >=dev-libs/c-blosc-1.11.1:0=
+ dev-libs/lzo:2=
+ >=dev-python/numpy-1.8.1[${PYTHON_USEDEP}]
+ >=dev-python/numexpr-2.5.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sci-libs/hdf5-1.8.15:0=
+"
+DEPEND="${RDEPEND}
+ >=dev-python/cython-0.21[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( RELEASE_NOTES.txt THANKS )
+
+python_prepare_all() {
+ export HDF5_DIR="${EPREFIX}"/usr
+ rm tables/*.c || die
+ sed -e "s:/usr:${EPREFIX}/usr:g" \
+ -i setup.py || die
+ rm -r c-blosc/{blosc,internal-complibs} || die
+ sed -i -e '/_version/ s/\\s\*/\\s\+/' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS}"
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${EPYTHON} tables/tests/test_all.py || die
+}
+
+python_install_all() {
+ if use doc; then
+ DOCS+=( doc/scripts )
+ fi
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ dodoc -r contrib
+ docompress -x /usr/share/doc/${PF}/examples
+ docompress -x /usr/share/doc/${PF}/contrib
+ fi
+}