summaryrefslogtreecommitdiff
path: root/dev-python/pytables/pytables-3.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 06:10:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 06:10:37 +0000
commit19a808581ca18addf4b12d09f7e440b7244679e5 (patch)
tree437f8a4d37be714e61ef02a9ee68f0616e860826 /dev-python/pytables/pytables-3.8.0-r1.ebuild
parentb256b4b120d8269d4415eac0c354eb603a7bf953 (diff)
gentoo auto-resync : 06:01:2023 - 06:10:36
Diffstat (limited to 'dev-python/pytables/pytables-3.8.0-r1.ebuild')
-rw-r--r--dev-python/pytables/pytables-3.8.0-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/pytables/pytables-3.8.0-r1.ebuild b/dev-python/pytables/pytables-3.8.0-r1.ebuild
index af123af3a0fa..661e90f4fe6e 100644
--- a/dev-python/pytables/pytables-3.8.0-r1.ebuild
+++ b/dev-python/pytables/pytables-3.8.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
+inherit distutils-r1 prefix
MY_PN=tables
MY_P=${MY_PN}-${PV}
@@ -62,6 +62,7 @@ python_prepare_all() {
rm -r c-blosc/{blosc,internal-complibs} || die
rm tables/libblosc2.so || die
sed -i -e '/blosc2/d' requirements.txt || die
+ hprefixify -w '/prefixes =/' setup.py
distutils-r1_python_prepare_all
}