summaryrefslogtreecommitdiff
path: root/dev-python/pytables/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-04 12:06:33 +0000
commita833e3f4a431b8eea751b7420e127787f9c92117 (patch)
treeb941d23e9e3d5f070b01feb15ef927839af7456a /dev-python/pytables/files
parent4cd2370bed609c118b6edfde5d3f116e5c35b897 (diff)
gentoo resync : 04.12.2017
Diffstat (limited to 'dev-python/pytables/files')
-rw-r--r--dev-python/pytables/files/pytables-3.1.1-blosc.patch16
-rw-r--r--dev-python/pytables/files/pytables-3.1.1-cython-backport.patch65
-rw-r--r--dev-python/pytables/files/pytables-3.1.1-numpy19-backport.patch51
3 files changed, 0 insertions, 132 deletions
diff --git a/dev-python/pytables/files/pytables-3.1.1-blosc.patch b/dev-python/pytables/files/pytables-3.1.1-blosc.patch
deleted file mode 100644
index 3a4ba18e5e73..000000000000
--- a/dev-python/pytables/files/pytables-3.1.1-blosc.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 2c0c126..1448eb1 100755
---- a/setup.py
-+++ b/setup.py
-@@ -768,7 +768,7 @@ if 'BLOSC' not in optional_libs:
- print("Setting compiler flag '-msse2'")
- CFLAGS.append("-msse2")
- else:
-- ADDLIBS += ['blosc']
-+ ADDLIBS += ['blosc', 'blosc_filter']
-
-
- utilsExtension_libs = LIBS + ADDLIBS
diff --git a/dev-python/pytables/files/pytables-3.1.1-cython-backport.patch b/dev-python/pytables/files/pytables-3.1.1-cython-backport.patch
deleted file mode 100644
index 7db41d2e1a62..000000000000
--- a/dev-python/pytables/files/pytables-3.1.1-cython-backport.patch
+++ /dev/null
@@ -1,65 +0,0 @@
- setup.py | 13 +++++++------
- tables/req_versions.py | 2 +-
- 2 files changed, 8 insertions(+), 7 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 0f2f3f7..52cda49 100755
---- a/setup.py
-+++ b/setup.py
-@@ -25,6 +25,7 @@ from distutils.core import Extension
- from distutils.dep_util import newer
- from distutils.util import convert_path
- from distutils.ccompiler import new_compiler
-+from distutils.version import LooseVersion
-
- cmdclass = {}
- setuptools_kwargs = {}
-@@ -106,7 +107,7 @@ def check_import(pkgname, pkgver):
- "You need %(pkgname)s %(pkgver)s or greater to run PyTables!"
- % {'pkgname': pkgname, 'pkgver': pkgver})
- else:
-- if mod.__version__ < pkgver:
-+ if mod.__version__ < LooseVersion(pkgver):
- exit_with_error(
- "You need %(pkgname)s %(pkgver)s or greater to run PyTables!"
- % {'pkgname': pkgname, 'pkgver': pkgver})
-@@ -122,21 +123,21 @@ if not has_setuptools:
-
- # Check if Cython is installed or not (requisite)
- try:
-+ from Cython import __version__ as cython_version
- from Cython.Distutils import build_ext
-- from Cython.Compiler.Main import Version
- cmdclass['build_ext'] = build_ext
- except ImportError:
- exit_with_error(
- "You need %(pkgname)s %(pkgver)s or greater to compile PyTables!"
- % {'pkgname': 'Cython', 'pkgver': min_cython_version})
-
--if Version.version < min_cython_version:
-+if LooseVersion(cython_version) < min_cython_version:
- exit_with_error(
-- "At least Cython %s is needed so as to generate extensions!"
-- % (min_cython_version))
-+ "You need %(pkgname)s %(pkgver)s or greater to run PyTables!"
-+ % {'pkgname': 'Cython', 'pkgver': min_cython_version})
- else:
- print("* Found %(pkgname)s %(pkgver)s package installed."
-- % {'pkgname': 'Cython', 'pkgver': Version.version})
-+ % {'pkgname': 'Cython', 'pkgver': cython_version})
-
- VERSION = open('VERSION').read().strip()
-
-diff --git a/tables/req_versions.py b/tables/req_versions.py
-index 2c9ca01..bd498c3 100644
---- a/tables/req_versions.py
-+++ b/tables/req_versions.py
-@@ -17,7 +17,7 @@
- # Minimum recommended versions for mandatory packages
- min_numpy_version = '1.4.1'
- min_numexpr_version = '2.0.0'
--min_cython_version = '0.13'
-+min_cython_version = '0.14'
-
- # The THG team has decided to fix an API inconsistency in the definition
- # of the H5Z_class_t structure in version 1.8.3
diff --git a/dev-python/pytables/files/pytables-3.1.1-numpy19-backport.patch b/dev-python/pytables/files/pytables-3.1.1-numpy19-backport.patch
deleted file mode 100644
index c2f0c2280f01..000000000000
--- a/dev-python/pytables/files/pytables-3.1.1-numpy19-backport.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 854d5798ca9fd78c00e18710de2e93202f675f3e Mon Sep 17 00:00:00 2001
-From: Antonio Valentino <antonio.valentino@tiscali.it>
-Date: Sun, 6 Jul 2014 21:21:39 +0200
-Subject: [PATCH] Fix a compatibility problem with numpy 1.9 (close: #362)
-
----
- RELEASE_NOTES.txt | 6 ++++++
- tables/table.py | 6 +++++-
- 2 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/RELEASE_NOTES.txt b/RELEASE_NOTES.txt
-index f219eb3..1da20e2 100644
---- a/RELEASE_NOTES.txt
-+++ b/RELEASE_NOTES.txt
-@@ -19,6 +19,12 @@ Improvements
- requiring strict access alignment.
-
-
-+Bugs fixed
-+----------
-+
-+- Fixed compatibitily problems with numpy 1.9 (closes :issue:`362`)
-+
-+
- Changes from 3.1.0 to 3.1.1
- ===========================
-
-diff --git a/tables/table.py b/tables/table.py
-index 235f599..ffe8fd6 100644
---- a/tables/table.py
-+++ b/tables/table.py
-@@ -3406,6 +3406,10 @@ def _getindex(self):
- associated with this column (None if the column is not
- indexed).""")
-
-+ @lazyattr
-+ def _itemtype(self):
-+ return self.descr._v_dtypes[self.name]
-+
- def _getshape(self):
- return (self.table.nrows,) + self.descr._v_dtypes[self.name].shape
-
-@@ -3529,7 +3533,7 @@ def __iter__(self):
- table = self.table
- itemsize = self.dtype.itemsize
- nrowsinbuf = table._v_file.params['IO_BUFFER_SIZE'] // itemsize
-- buf = numpy.empty((nrowsinbuf, ), self.dtype)
-+ buf = numpy.empty((nrowsinbuf, ), self._itemtype)
- max_row = len(self)
- for start_row in xrange(0, len(self), nrowsinbuf):
- end_row = min(start_row + nrowsinbuf, max_row)