summaryrefslogtreecommitdiff
path: root/dev-python/pystache/pystache-0.6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-08 22:31:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-08 22:31:44 +0100
commit07e5258263817a33e6c141c7f2626f909688bdb1 (patch)
tree672db8f3d96096edfd3ef013d3869640a9856a0d /dev-python/pystache/pystache-0.6.5.ebuild
parent5e2dc8e9ee14034d872c67b64a63af413f63ad47 (diff)
gentoo auto-resync : 08:09:2023 - 22:31:44
Diffstat (limited to 'dev-python/pystache/pystache-0.6.5.ebuild')
-rw-r--r--dev-python/pystache/pystache-0.6.5.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/pystache/pystache-0.6.5.ebuild b/dev-python/pystache/pystache-0.6.5.ebuild
index c10cd9359cc2..3c70a630edb7 100644
--- a/dev-python/pystache/pystache-0.6.5.ebuild
+++ b/dev-python/pystache/pystache-0.6.5.ebuild
@@ -30,9 +30,23 @@ LICENSE="MIT"
SLOT="0"
BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
test? (
dev-python/pyyaml[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
+
+distutils_enable_sphinx \
+ docs/source \
+ dev-python/sphinx-rtd-theme \
+ dev-python/recommonmark \
+ dev-python/sphinxcontrib-apidoc
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ sed -i '/sphinx_git/d' "${S}"/setup.cfg "${S}"/docs/source/conf.py
+ default
+}