summaryrefslogtreecommitdiff
path: root/dev-python/pyspnego
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pyspnego
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pyspnego')
-rw-r--r--dev-python/pyspnego/Manifest4
-rw-r--r--dev-python/pyspnego/pyspnego-0.4.0.ebuild44
-rw-r--r--dev-python/pyspnego/pyspnego-0.5.0.ebuild44
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/pyspnego/Manifest b/dev-python/pyspnego/Manifest
index 86503e8ba1ae..4d9352515f77 100644
--- a/dev-python/pyspnego/Manifest
+++ b/dev-python/pyspnego/Manifest
@@ -1,3 +1,7 @@
DIST pyspnego-0.3.1.tar.gz 308888 BLAKE2B 23d77718bcb3deb807764ef3098c8f25b487c18b022ba9e48bc46bbab8f77de82ddc4a2bd66485041b1012958304d77236f54e9f87150e68631045bd50ca2a0a SHA512 2f46c727dbb29e1b9a7e4912c14fe49f47595ef7134358eae03e0645cce927e69e3612d11b1b5986fbb945f684e87d6eddf08bc6153af9d29325718a6207e3a1
+DIST pyspnego-0.4.0.tar.gz 324322 BLAKE2B 97ef46ba072df46f873a9f2bdf4dd440a37395a87856da92b5438af8ed05aad381189eb86b6fe031ab77158c482f91a3fb12dde69082decfbe328c150d8210f0 SHA512 e110bffebf746e7ef1c1bd74e071ec7b224c30cf7be12f6c1101feb58d85fa6f4fa48e946e1a620115b2857dcad07c77986800d623cc1a94b24a253d3205b9ea
+DIST pyspnego-0.5.0.tar.gz 325693 BLAKE2B 7674f498624e9b3c463db9ee60e9c5edf84cefd3642c9fe2cf0df58364c96b0643cf962d00edf1a6be9d8452e344e920cc1edec70bc39e8f65a6428204c36328 SHA512 4abb5726f9432366453069d32344b2be2169301cb0a6f96bcaac3f49f807c2ba819ad85a50f7979e920ddf3a4dcd13f6fc868e8d72c3c00cd3b9ffc97692b4c8
EBUILD pyspnego-0.3.1.ebuild 863 BLAKE2B a919ee52e45c16141682ecfa2752af406646ceb5e386893ced19c24b4d81a2a554a2b29c9c19e3b6629f1e098987245327acd3740e74dc91c5eb1ae24e9d73a9 SHA512 b5256dcd898b145b88639f024fd47559ec9fd6cc887f456c623e0e441cc642d15150f51d798cd0027d5b525b214a0c01ed605d08bbab8b474dee3fca90548746
+EBUILD pyspnego-0.4.0.ebuild 1259 BLAKE2B 5749f5a00a68c449cb44d9866e96f937340af01831c520554b252d888cc53050042bff7f1f630066fdebd756316e10309bf7ed389a377d15c5df72e292c0b37e SHA512 7ff67b73d2c0528cd61f1a2c66cd836e64daae623ff60936f4b682e16b5afa8b64436ca86c661d62c92720634c2159dce7e8bac7865222bb014f1eee1b7625d6
+EBUILD pyspnego-0.5.0.ebuild 1259 BLAKE2B 5749f5a00a68c449cb44d9866e96f937340af01831c520554b252d888cc53050042bff7f1f630066fdebd756316e10309bf7ed389a377d15c5df72e292c0b37e SHA512 7ff67b73d2c0528cd61f1a2c66cd836e64daae623ff60936f4b682e16b5afa8b64436ca86c661d62c92720634c2159dce7e8bac7865222bb014f1eee1b7625d6
MISC metadata.xml 370 BLAKE2B 113adf1bd70a99f41e2b8cd4d5bb69cbd4f6bffa1dba325a8a6e35a1b5ee2800ef1d4b9ceec9be2ad1291fdd054fa81fdb841cdf40b5e969360bf1ee2e456960 SHA512 baa8a1fee20b0cea6308fbfa24fc395cd58e8729eb703692cc2a109e838284ec21559d4c9af3c99fe6d63ac6a8e04e3a3c824cb073302f788f2fa5dcf1dbf00c
diff --git a/dev-python/pyspnego/pyspnego-0.4.0.ebuild b/dev-python/pyspnego/pyspnego-0.4.0.ebuild
new file mode 100644
index 000000000000..27b39859d871
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="https://pypi.org/project/pyspnego/ https://github.com/jborean93/pyspnego"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # https://github.com/jborean93/pyspnego/issues/33
+ 'tests/test_auth.py::test_kerberos_auth_keytab[negotiate-False]'
+ 'tests/test_auth.py::test_kerberos_auth_keytab[negotiate-True]'
+ 'tests/test_auth.py::test_kerberos_auth_ccache[negotiate-False]'
+ 'tests/test_auth.py::test_kerberos_auth_env_cache[negotiate-False]'
+)
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}
diff --git a/dev-python/pyspnego/pyspnego-0.5.0.ebuild b/dev-python/pyspnego/pyspnego-0.5.0.ebuild
new file mode 100644
index 000000000000..27b39859d871
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="https://pypi.org/project/pyspnego/ https://github.com/jborean93/pyspnego"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # https://github.com/jborean93/pyspnego/issues/33
+ 'tests/test_auth.py::test_kerberos_auth_keytab[negotiate-False]'
+ 'tests/test_auth.py::test_kerberos_auth_keytab[negotiate-True]'
+ 'tests/test_auth.py::test_kerberos_auth_ccache[negotiate-False]'
+ 'tests/test_auth.py::test_kerberos_auth_env_cache[negotiate-False]'
+)
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}