summaryrefslogtreecommitdiff
path: root/dev-python/pyspnego/pyspnego-0.10.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-04 11:51:15 +0100
commit713e25c0c3d1e5434ac60ec0549708ec2f744bb4 (patch)
tree9e9281ff07875c667fb3bf223166de68137f4635 /dev-python/pyspnego/pyspnego-0.10.2.ebuild
parent08b4047e14c989cfb931eff95973837f54ccc9e1 (diff)
gentoo auto-resync : 04:10:2023 - 11:51:15
Diffstat (limited to 'dev-python/pyspnego/pyspnego-0.10.2.ebuild')
-rw-r--r--dev-python/pyspnego/pyspnego-0.10.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyspnego/pyspnego-0.10.2.ebuild b/dev-python/pyspnego/pyspnego-0.10.2.ebuild
new file mode 100644
index 000000000000..408e9482cad6
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.10.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}