summaryrefslogtreecommitdiff
path: root/dev-python/pyspectrum2/pyspectrum2-0.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-04 03:13:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-04 03:13:19 +0000
commit1f709ed82b8014b4c156f87c66cee7d0d1d3905d (patch)
treee2a478d1bbdb4f68ce4d30908ca0e21ca984a602 /dev-python/pyspectrum2/pyspectrum2-0.2.0-r2.ebuild
parent924750a8c767b278c9870be5dcfedced436f1276 (diff)
gentoo auto-resync : 04:11:2022 - 03:13:18
Diffstat (limited to 'dev-python/pyspectrum2/pyspectrum2-0.2.0-r2.ebuild')
-rw-r--r--dev-python/pyspectrum2/pyspectrum2-0.2.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyspectrum2/pyspectrum2-0.2.0-r2.ebuild b/dev-python/pyspectrum2/pyspectrum2-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..e35e6be56f12
--- /dev/null
+++ b/dev-python/pyspectrum2/pyspectrum2-0.2.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a protobuf-based interface for Spectrum2 python-based backends"
+HOMEPAGE="https://github.com/stv0g/pyspectrum2"
+SRC_URI="https://github.com/stv0g/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-python/protobuf-python[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ python_optimize
+}