summaryrefslogtreecommitdiff
path: root/dev-python/pysmi/pysmi-0.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/pysmi/pysmi-0.3.4.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/pysmi/pysmi-0.3.4.ebuild')
-rw-r--r--dev-python/pysmi/pysmi-0.3.4.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pysmi/pysmi-0.3.4.ebuild b/dev-python/pysmi/pysmi-0.3.4.ebuild
index a25f52054908..65ae6d0c5a5b 100644
--- a/dev-python/pysmi/pysmi-0.3.4.ebuild
+++ b/dev-python/pysmi/pysmi-0.3.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2017-2020 Gentoo Authors
+# Copyright 2017-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Python Lex & Yacc"
@@ -15,4 +15,6 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-python/pysnmp[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest