summaryrefslogtreecommitdiff
path: root/dev-python/pyside6/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-23 14:44:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-23 14:44:46 +0100
commitcdfd4f0c915964d401cba19362c7dea8e89ad1da (patch)
treef6d313d1b57913d1309e00a578166e1e10fa6b8d /dev-python/pyside6/files
parent05a34d98821265bf73820931936f86704b9002c6 (diff)
gentoo auto-resync : 23:08:2022 - 14:44:46
Diffstat (limited to 'dev-python/pyside6/files')
-rw-r--r--dev-python/pyside6/files/pyside6-6.3.1-fix-designer-plugin-install-location.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/pyside6/files/pyside6-6.3.1-fix-designer-plugin-install-location.patch b/dev-python/pyside6/files/pyside6-6.3.1-fix-designer-plugin-install-location.patch
new file mode 100644
index 000000000000..b7d1c2b31553
--- /dev/null
+++ b/dev-python/pyside6/files/pyside6-6.3.1-fix-designer-plugin-install-location.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/865363
+
+From 109d7bbec01870f8e944a9cde09d3e2f70e13e0d Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Mon, 22 Aug 2022 07:10:35 +0200
+Subject: [PATCH] fix designer plugin install location
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/plugins/designer/CMakeLists.txt
++++ b/plugins/designer/CMakeLists.txt
+@@ -53,4 +53,4 @@ target_link_libraries(PySidePlugin PRIVATE
+ Qt::Widgets
+ ${SHIBOKEN_PYTHON_LIBRARIES})
+
+-install(TARGETS PySidePlugin LIBRARY DESTINATION "plugins/designer")
++install(TARGETS PySidePlugin LIBRARY DESTINATION "lib${LIB_SUFFIX}/qt6/plugins/designer")