summaryrefslogtreecommitdiff
path: root/dev-python/pyside6-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-09 00:08:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-09 00:08:14 +0100
commit4fe228ee9aa3b9b825d54ace549a5517e153e8bd (patch)
tree90a261e3ea59b80722d70d3c42f3e40d16c9f8dd /dev-python/pyside6-tools
parentadc09cc4e6ebf7931735c02c0c272b4b885c2b30 (diff)
gentoo auto-resync : 09:06:2024 - 00:08:13
Diffstat (limited to 'dev-python/pyside6-tools')
-rw-r--r--dev-python/pyside6-tools/Manifest2
-rw-r--r--dev-python/pyside6-tools/pyside6-tools-6.7.0.ebuild76
2 files changed, 0 insertions, 78 deletions
diff --git a/dev-python/pyside6-tools/Manifest b/dev-python/pyside6-tools/Manifest
index c490fc18b9b6..87286f33d11f 100644
--- a/dev-python/pyside6-tools/Manifest
+++ b/dev-python/pyside6-tools/Manifest
@@ -1,5 +1,3 @@
-DIST pyside-setup-everywhere-src-6.7.0.tar.xz 14382456 BLAKE2B 607e496cdeb7e55166b4f0dc15662a8792c7d8925856e8edbb927dfdc33342d158f430e3433d3d4a78ea33740e333fb2422ea1f4332408c3c6214f92d31bdd0d SHA512 7801d564d8d359edec431dc0e6f170538b9fc6f834cb7ab8eff41c1989bffb619c446d4d62d65db2a5b7592c0bff5d450d42de2797726658fe1a8f53df8a4c14
DIST pyside-setup-everywhere-src-6.7.1.tar.xz 14400976 BLAKE2B 1f6e2705aedc4151147e259da2a8fbab19a1815f19f1a36ea46dbf0bf2282a453e85a33ea8c6862072bb22699be39ab8375b48cd6d5b879de8bed5fad8cf60cb SHA512 6ca73f0b16ef43bc018aeb9e0f51d8ae91b13b79ebdfd71f5524bc0e8ef78322ba0aca81203cc5532e5096a55441fb4dabf3b628de3234b876b7a70327b714d4
-EBUILD pyside6-tools-6.7.0.ebuild 1768 BLAKE2B ccd9ba0f0cf047abab5993838975913fb268c75dc8975c04b5300ac715d98342fdaa579323462ae43cb29bc994f54b1c6e63bc35b71e180c892b18a94ae937db SHA512 d2795ada922c9d6c38560a7254c0ef8957c06985ac89fb54e79626470dd5b7344a834d57bcaae7bc5e0513ec9e7d68788e2b8bec22b2fc7737f9febc773ffbf0
EBUILD pyside6-tools-6.7.1.ebuild 1883 BLAKE2B 6b70960f280acb0d1e822ca83f8543d04dcd17844547e93facab031040725acdcbc385a7adccdb6e2e6a15b834ce31e5c24419208f0160f57d3a86365f341f8e SHA512 e329b5cb4d717fe27fed7ba548a9e26b44d29031c3c33d87360b287b7784f0190a06ab22b81a083ef5e22b0499ec34e73a92ae3292650178894f63992779fd0d
MISC metadata.xml 402 BLAKE2B 28348df442d189eadb56e04dfda71c1d5a56868aae85611a7d77ecdc7651e34ce02563c8da1270aad55758e2dd4301de44434e0bbdb010ef484e240068602ede SHA512 a54866110e38c24d67d60286c64b63dc0b537c55eb201b84b9173b47710b6e8a840d9072ca46fbef969bf481e43e1d8824b20655d7fe6b300cfd5333c3f74a41
diff --git a/dev-python/pyside6-tools/pyside6-tools-6.7.0.ebuild b/dev-python/pyside6-tools/pyside6-tools-6.7.0.ebuild
deleted file mode 100644
index ff038e50d1f2..000000000000
--- a/dev-python/pyside6-tools/pyside6-tools-6.7.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# TODO: Add PyPy once officially supported. See also:
-# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{10..13} )
-
-LLVM_COMPAT=( {15..18} )
-
-inherit cmake llvm-r1 python-r1
-
-MY_PN="pyside-setup-everywhere-src"
-
-DESCRIPTION="PySide development tools (pyside6-lupdate with support for Python)"
-HOMEPAGE="https://wiki.qt.io/PySide6"
-SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside6/PySide6-${PV}-src/${MY_PN}-${PV}.tar.xz"
-S="${WORKDIR}/${MY_PN}-${PV}/sources/pyside-tools"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- ~dev-python/shiboken6-${PV}[${PYTHON_USEDEP},${LLVM_USEDEP}]
- ~dev-python/pyside6-${PV}[quick,${PYTHON_USEDEP},${LLVM_USEDEP}]
-"
-DEPEND="${RDEPEND}
- $(llvm_gen_dep '
- sys-devel/clang:${LLVM_SLOT}
- sys-devel/llvm:${LLVM_SLOT}
- ')
-"
-
-src_prepare() {
- cmake_src_prepare
-
- python_copy_sources
-}
-
-src_configure() {
- pyside-tools_configure() {
- local mycmakeargs=(
- # If this is enabled cmake just makes copies of /lib64/qt6/bin/*
- -DNO_QT_TOOLS=yes
- )
- cmake_src_configure
- }
-
- python_foreach_impl pyside-tools_configure
-}
-
-src_compile() {
- pyside-tools_compile() {
- cmake_src_compile
- }
-
- python_foreach_impl pyside-tools_compile
-}
-
-src_install() {
- pyside-tools_install() {
- # This replicates the contents of the PySide6 pypi wheel
- DESTDIR="${BUILD_DIR}" cmake_build install
- cp __init__.py "${BUILD_DIR}/usr/bin" || die
- rm -r "${BUILD_DIR}/usr/bin/qtpy2cpp_lib/tests" || die
- python_moduleinto PySide6/scripts
- python_domodule "${BUILD_DIR}/usr/bin/."
- }
-
- python_foreach_impl pyside-tools_install
-
- einstalldocs
-}