summaryrefslogtreecommitdiff
path: root/dev-python/pyserial/pyserial-3.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-08 00:08:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-08 00:08:11 +0100
commitadc09cc4e6ebf7931735c02c0c272b4b885c2b30 (patch)
treed1e752b60c2ed90ae9e427cbe2b07061e3879191 /dev-python/pyserial/pyserial-3.5-r2.ebuild
parent941687623283212199cbe6e36f7d61b89d6222b2 (diff)
gentoo auto-resync : 08:06:2024 - 00:08:11
Diffstat (limited to 'dev-python/pyserial/pyserial-3.5-r2.ebuild')
-rw-r--r--dev-python/pyserial/pyserial-3.5-r2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pyserial/pyserial-3.5-r2.ebuild b/dev-python/pyserial/pyserial-3.5-r2.ebuild
index a8e14ce8e27f..76c7aed077f9 100644
--- a/dev-python/pyserial/pyserial-3.5-r2.ebuild
+++ b/dev-python/pyserial/pyserial-3.5-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -21,6 +21,10 @@ IUSE="examples"
DOCS=( CHANGES.rst README.rst )
+PATCHES=(
+ "${FILESDIR}/${P}-unittest-fix.patch"
+)
+
distutils_enable_sphinx documentation --no-autodoc
python_test() {