summaryrefslogtreecommitdiff
path: root/dev-python/pyscreenshot/pyscreenshot-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-12 18:13:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-12 18:13:14 +0000
commitf1ced5f5f09c4d27185e6986a465f7bc3b828c65 (patch)
treebb4a65f6889f3cbcc2f8e5053b624f23291d7921 /dev-python/pyscreenshot/pyscreenshot-3.1.ebuild
parent70d27c1344f6a6a51e11c610966542333b6f432a (diff)
gentoo auto-resync : 12:03:2023 - 18:13:14
Diffstat (limited to 'dev-python/pyscreenshot/pyscreenshot-3.1.ebuild')
-rw-r--r--dev-python/pyscreenshot/pyscreenshot-3.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pyscreenshot/pyscreenshot-3.1.ebuild b/dev-python/pyscreenshot/pyscreenshot-3.1.ebuild
new file mode 100644
index 000000000000..47b82756e769
--- /dev/null
+++ b/dev-python/pyscreenshot/pyscreenshot-3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python screenshot library"
+HOMEPAGE="
+ https://github.com/ponty/pyscreenshot/
+ https://pypi.org/project/pyscreenshot/
+"
+SRC_URI="
+ https://github.com/ponty/pyscreenshot/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/entrypoint2[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ dev-python/mss[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ media-gfx/pqiv
+ x11-apps/xdpyinfo
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_check.py::test_speedtest
+ )
+
+ # skip GNOME/KDE tests that require D-BUS
+ local -x XDG_CURRENT_DESKTOP=none
+ # nonfatal is already implied by virtx, make it explicit though
+ nonfatal epytest || die "Tests failed with ${EPYTHON}"
+}