summaryrefslogtreecommitdiff
path: root/dev-python/pyscard/pyscard-2.0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 18:30:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 18:30:39 +0100
commit68a32bc9fda17e8a546c0bba9d113c4c4659f6bb (patch)
treee043bb32648a3c75289450c0f4252aaabc1d4593 /dev-python/pyscard/pyscard-2.0.9.ebuild
parent74a32c3ccafc7895a037d2b0cf73fc726286ec2e (diff)
gentoo auto-resync : 06:04:2024 - 18:30:38
Diffstat (limited to 'dev-python/pyscard/pyscard-2.0.9.ebuild')
-rw-r--r--dev-python/pyscard/pyscard-2.0.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyscard/pyscard-2.0.9.ebuild b/dev-python/pyscard/pyscard-2.0.9.ebuild
new file mode 100644
index 000000000000..b141ab35e303
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="
+ https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}