summaryrefslogtreecommitdiff
path: root/dev-python/pyscard/pyscard-1.9.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyscard/pyscard-1.9.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyscard/pyscard-1.9.5.ebuild')
-rw-r--r--dev-python/pyscard/pyscard-1.9.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pyscard/pyscard-1.9.5.ebuild b/dev-python/pyscard/pyscard-1.9.5.ebuild
new file mode 100644
index 000000000000..4d8569d2425b
--- /dev/null
+++ b/dev-python/pyscard/pyscard-1.9.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Smart cards support in python"
+HOMEPAGE="http://pyscard.sourceforge.net/ https://pypi.python.org/pypi/pyscard"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RDEPEND="sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-lang/swig"
+
+# Fails
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/pyro
+}