summaryrefslogtreecommitdiff
path: root/dev-python/pyrsistent/pyrsistent-0.17.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pyrsistent/pyrsistent-0.17.3.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pyrsistent/pyrsistent-0.17.3.ebuild')
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.17.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/pyrsistent-0.17.3.ebuild b/dev-python/pyrsistent/pyrsistent-0.17.3.ebuild
new file mode 100644
index 000000000000..e732f866136e
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.17.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="https://github.com/tobgu/pyrsistent/ https://pypi.org/project/pyrsistent/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest