summaryrefslogtreecommitdiff
path: root/dev-python/pyrqlite/pyrqlite-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-08 23:39:55 +0100
commit2c359e29620429f94a60fc1e832048e54ee41eb5 (patch)
tree3a24152899725be0796179577e84caf957a80ce3 /dev-python/pyrqlite/pyrqlite-2.2.0.ebuild
parentd6a3ca89e16356791af128f18ca5d5aeaf1323e0 (diff)
gentoo auto-resync : 08:05:2023 - 23:39:55
Diffstat (limited to 'dev-python/pyrqlite/pyrqlite-2.2.0.ebuild')
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.2.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyrqlite/pyrqlite-2.2.0.ebuild b/dev-python/pyrqlite/pyrqlite-2.2.0.ebuild
new file mode 100644
index 000000000000..81e617621537
--- /dev/null
+++ b/dev-python/pyrqlite/pyrqlite-2.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for rqlite"
+HOMEPAGE="https://github.com/rqlite/pyrqlite"
+SRC_URI="
+ https://github.com/rqlite/pyrqlite/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( >=dev-db/rqlite-6.7.0 )"
+
+distutils_enable_tests pytest